summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2021-10-08 03:47:21 +0200
committerJulien Lepiller <julien@lepiller.eu>2021-10-08 04:33:58 +0200
commit26dd2321febf5290cce2f26d8f341b0e85607ebd (patch)
tree96d67eb5bab488f9e36ae362c30a7e3fd70d4025 /gnu/packages/maths.scm
parent24fba107d156ef718ef6e1002a5a29a55dc2a275 (diff)
downloadguix-patches-26dd2321febf5290cce2f26d8f341b0e85607ebd.tar
guix-patches-26dd2321febf5290cce2f26d8f341b0e85607ebd.tar.gz
gnu: why3: Update to 1.4.0.
* gnu/packages/maths.scm (why3): Update to 1.4.0.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 95ce13f312..2c7202b4e0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6903,17 +6903,21 @@ numeric differences and differences in numeric formats.")
(define-public why3
(package
(name "why3")
- (version "1.3.3")
+ (version "1.4.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://gforge.inria.fr/frs/download.php/file"
- "/38367/why3-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/why3/why3")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1n0a2nn1gnk0zg339lh698g4wpk7m8m1vyi2yvifd5adqvk4milw"))))
+ "0pfsiddnk26f384wbazfpgzh1n1ibf3xq101q74mxvczi7z0a791"))))
(build-system ocaml-build-system)
(native-inputs
- `(("coq" ,coq)
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("coq" ,coq)
("ocaml" ,ocaml)
("which" ,which)))
(propagated-inputs
@@ -6929,10 +6933,12 @@ numeric differences and differences in numeric formats.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-before 'configure 'fix-configure
+ (add-before 'configure 'bootstrap
(lambda _
+ (invoke "./autogen.sh")
(setenv "CONFIG_SHELL" (which "sh"))
(substitute* "configure"
+ (("#! /bin/sh") (string-append "#!" (which "sh")))
;; find ocaml-num in the correct directory
(("\\$DIR/nums.cma") "$DIR/num.cma")
(("\\$DIR/num.cmi") "$DIR/core/num.cmi"))