summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-11-22 06:47:30 +0100
committerMarius Bakke <marius@gnu.org>2022-11-22 08:37:24 +0100
commit41ca8f9c207a04f266b061ec91cb9031967ed109 (patch)
treefe132c401d9353dd08ec6995339da58ee65e558b /gnu/packages/maths.scm
parentdc7397845dbb85eee83f8d2a890a479690d60a5a (diff)
downloadguix-patches-41ca8f9c207a04f266b061ec91cb9031967ed109.tar
guix-patches-41ca8f9c207a04f266b061ec91cb9031967ed109.tar.gz
gnu: dune-alugrid: Fix build failure.
* gnu/packages/maths.scm (dune-alugrid)[arguments]: Provide the INPUTS key in build-tests phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 15c020e6c4..98bae9ecb5 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6811,7 +6811,7 @@ assemble global function spaces on finite-element grids.")
"doc/dune-grid/grids/gridfactory/testgrids"))
#t))
(add-after 'build 'build-tests
- (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (lambda* (#:key inputs make-flags parallel-build? #:allow-other-keys)
(setenv "CPLUS_INCLUDE_PATH"
(string-append (assoc-ref inputs "dune-grid") "/share"))
(apply invoke "make" "build_tests"