summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-26 13:48:28 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 22:58:33 +0200
commit40f96ea6679ab904c4535db9c4ec9c5f994ec484 (patch)
treed79a2974120168e2f50302c155e0870438d4573b /gnu/packages/make-bootstrap.scm
parent6c80f4949fa1a5aa766f7f3834d75463b77cd107 (diff)
downloadguix-patches-40f96ea6679ab904c4535db9c4ec9c5f994ec484.tar
guix-patches-40f96ea6679ab904c4535db9c4ec9c5f994ec484.tar.gz
gnu: binutils: Update to 2.38.
If this commit gives a deja vu, you are not dreaming; see commit 3e3a37b2bcb1f23011fde8626559f83504177889. * gnu/packages/base.scm (binutils): Update to 2.38. [source](patches): Remove obsolete. [arguments]: Add #:make-flags. [properties]: New field. (binutils+documentation): New variable. (binutils-gold): Inherit from BINUTILS+DOCUMENTATION. * gnu/packages/make-bootstrap.scm (%binutils-static)[arguments]: Inherit #:make-flags. * gnu/packages/patches/binutils-2.37-file-descriptor-leak.patch, gnu/packages/patches/binutils-CVE-2021-45078.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 4ea97368a9..326ddf561e 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2018, 2019, 2021 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
-;;; Copyright © 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2019, 2020, 2022 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
;;;
@@ -388,6 +388,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(package-arguments binutils))
((#:configure-flags flags _ ...)
flags)))
+ #:make-flags ,(match (memq #:make-flags (package-arguments binutils))
+ ((#:make-flags flags _ ...)
+ flags)
+ (_ ''()))
#:strip-flags '("--strip-all")
#:phases (modify-phases %standard-phases
(add-before 'configure 'all-static