summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorng0 <contact.ng0@cryptolab.net>2017-03-24 16:45:57 +0000
committerLudovic Courtès <ludo@gnu.org>2017-04-07 23:30:38 +0200
commitcf47a8a51dfbc9b6358da29b2d4f150ef732d163 (patch)
tree83965b073dc25f0af1f95bdbfbdb0e9993d57de4 /gnu/packages/mail.scm
parent1165b08f8683b2a8c12753eb6fd26c2451bce81c (diff)
downloadguix-patches-cf47a8a51dfbc9b6358da29b2d4f150ef732d163.tar
guix-patches-cf47a8a51dfbc9b6358da29b2d4f150ef732d163.tar.gz
gnu: dovecot-trees: Update to 2.1.0.
* gnu/packages/mail.scm (dovecot-trees): Update to 2.1.0. (source): Change to use 'url-fetch'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm75
1 files changed, 36 insertions, 39 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65fa9df544..13861a8ad4 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1132,44 +1132,41 @@ It supports mbox/Maildir and its own dbox/mdbox formats.")
(license (list lgpl2.1 license:expat (non-copyleft "file://COPYING")))))
(define-public dovecot-trees
- (let ((commit "006059c8a47d68f14f73c09743e45b9a73014dbf")
- (revision "1"))
- (package
- (name "dovecot-trees")
- (version (string-append "2.0.0-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://0xacab.org/riseuplabs/trees.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0ax90bzc66x179wi1m7ywqwa8nssyhjngs7ij109hqqxg5ymfp73"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("automake" ,automake)
- ("autoconf" ,autoconf)
- ("libtool" ,libtool)
- ("dovecot" ,dovecot)
- ("pkg-config" ,pkg-config)))
- (inputs
- `(("libsodium" ,libsodium)))
- (arguments
- `(#:tests? #f ;No tests exist.
- #:configure-flags (list (string-append "--with-dovecot="
- (assoc-ref %build-inputs "dovecot")
- "/lib/dovecot"))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'autogen
- (lambda _
- (zero? (system* "./autogen.sh")))))))
- (home-page "https://0xacab.org/riseuplabs/trees")
- (synopsis "NaCL-based Dovecot email storage encryption plugin")
- (description
- "Technology for Resting Email Encrypted Storage (TREES) is a NaCL-based
+ (package
+ (name "dovecot-trees")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://0xacab.org/riseuplabs/trees/repository/"
+ "archive.tar.gz?ref=v" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rkk10b1bsjz979sc864vpgcdchy7yxwmyv4ik50lar1h6awdnrf"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("automake" ,automake)
+ ("autoconf" ,autoconf)
+ ("libtool" ,libtool)
+ ("dovecot" ,dovecot)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libsodium" ,libsodium)))
+ (arguments
+ `(#:tests? #f ;No tests exist.
+ #:configure-flags (list (string-append "--with-dovecot="
+ (assoc-ref %build-inputs "dovecot")
+ "/lib/dovecot"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'autogen
+ (lambda _
+ (zero? (system* "./autogen.sh")))))))
+ (home-page "https://0xacab.org/riseuplabs/trees")
+ (synopsis "NaCL-based Dovecot email storage encryption plugin")
+ (description
+ "Technology for Resting Email Encrypted Storage (TREES) is a NaCL-based
Dovecot encryption plugin. This plugin adds individually encrypted mail
storage to the Dovecot IMAP server. It is inspired by Posteo's scrambler
which uses OpenSSL and RSA keypairs. TREES works in a similar way, but uses
@@ -1185,7 +1182,7 @@ How it works:
using lidsodium sealed boxes.
@item New mail is encrypted as it arrives using the Curve25519 public key.
@end enumerate\n")
- (license agpl3))))
+ (license agpl3)))
(define-public dovecot-libsodium-plugin
(let ((commit "044de73c01c35385df0105f6b387bec5d5317ce7")