summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-09 13:38:53 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-09-09 20:48:31 -0400
commit173b6f6f154ab214b89f063ff3a67ea3207347ec (patch)
tree53ad46f32c559ddd4a0f6c9ce2b558a8fefa2f2a /gnu/packages/mail.scm
parentd8a184f086fb1b434628f8e486c14c2daf716ce9 (diff)
downloadguix-patches-173b6f6f154ab214b89f063ff3a67ea3207347ec.tar
guix-patches-173b6f6f154ab214b89f063ff3a67ea3207347ec.tar.gz
gnu: mailutils: Update to 3.13.
* gnu/packages/patches/mailutils-fix-uninitialized-variable.patch: Remove patch. * gnu/local.mk (dist_patch_DATA): De-register it. * gnu/packages/mail.scm (mailutils): Update to 3.13. Remove the 2013 --with-sql option TODO comment; if someone needs that, they can send a patch. [source]: Remove above patch. [phases]{prepare-test-suite}: Also patch shell shebang in 'libmailutils/tests/lock.at' and 'imap4d/tests/testclient.c'. [parallel-tests?]: Reinstate parallel tests. [inputs]: Move m4 to... [native-inputs]: ... here. Add the autoconf, automake, gettext and libtool quartet.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm35
1 files changed, 19 insertions, 16 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index bf0ae0041c..0ccd719d68 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -260,18 +260,16 @@ example, modify the message headers or body, or encrypt or sign the message.")
(define-public mailutils
(package
(name "mailutils")
- (version "3.10")
+ (version "3.13")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/mailutils/mailutils-"
version ".tar.xz"))
(sha256
(base32
- "17smrxjdgbbzbzakik30vj46q4iib85ksqhb82jr4vjp57akszh9"))
+ "1iwl82d6aa2acsdxbqh1s5xx44sg83b4yxqik408m1s9rcfrf86r"))
(patches
- ;; Fixes https://issues.guix.gnu.org/43088.
- (search-patches "mailutils-fix-uninitialized-variable.patch"
- "mailutils-variable-lookup.patch"))))
+ (search-patches "mailutils-variable-lookup.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -295,8 +293,9 @@ example, modify the message headers or body, or encrypt or sign the message.")
;; The 'pipeact.at' tests generate a shell script; make
;; sure it uses the right shell.
(substitute* '("sieve/tests/testsuite"
- "mh/tests/testsuite")
- (("#! /bin/sh")
+ "mh/tests/testsuite"
+ "libmailutils/tests/lock.at")
+ (("#! ?/bin/sh")
(string-append "#!" (which "sh"))))
(substitute* "mh/tests/testsuite"
@@ -328,8 +327,9 @@ example, modify the message headers or body, or encrypt or sign the message.")
(format port "Path: ~a/Mail-for-tests~%"
(getcwd))))
- #t)))
- ;; TODO: Add `--with-sql'.
+ (substitute* "imap4d/tests/testclient.c"
+ (("\"/bin/sh\"")
+ (string-append "\"" (which "sh") "\""))))))
#:configure-flags
(list "--sysconfdir=/etc"
@@ -341,16 +341,20 @@ example, modify the message headers or body, or encrypt or sign the message.")
(package-inputs this-package))
(("guile" guile)
(version-major+minor
- (package-version guile))))))
-
- #:parallel-tests? #f))
+ (package-version guile))))))))
(native-inputs
- `(("perl" ,perl) ;for 'gylwrap'
+ ;; Regeneration of the build system is triggered by touching the
+ ;; 'libmailutils/tests/lock.at' file.
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)
+ ("libtool" ,libtool)
+ ("m4" ,m4)
+ ("perl" ,perl) ;for 'gylwrap'
("texinfo" ,texinfo)
("dejagnu" ,dejagnu)))
(inputs
- `(("m4" ,m4)
- ("guile" ,guile-3.0)
+ `(("guile" ,guile-3.0)
("gsasl" ,gsasl)
("gnutls" ,gnutls)
("ncurses" ,ncurses)
@@ -358,7 +362,6 @@ example, modify the message headers or body, or encrypt or sign the message.")
("linux-pam" ,linux-pam)
("libltdl" ,libltdl)
("gdbm" ,gdbm)
-
;; Required for SEARCH CHARSET.
("libiconv" ,libiconv)
("libunistring" ,libunistring)))