summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTroy Sankey <sankeytms@gmail.com>2016-08-13 12:09:22 -0400
committerMark H Weaver <mhw@netris.org>2016-08-23 06:39:50 -0400
commit1b94f1827a7ec57fea48bf852b2be46c560a23c2 (patch)
treefc64e64697b2b6a4f2e6723e9f0de34efb51d131 /gnu/packages/mail.scm
parent37ec462392f9c645274ddf7ce020cbb3dd589332 (diff)
downloadguix-patches-1b94f1827a7ec57fea48bf852b2be46c560a23c2.tar
guix-patches-1b94f1827a7ec57fea48bf852b2be46c560a23c2.tar.gz
gnu: alot: Fixup comments.
* gnu/packages/mail.scm (alot): Add note about distribution method, and adhere to double semi-colon norm. Signed-off-by: Mark H Weaver <mhw@netris.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 99af84519e..bec3bc5ad6 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -408,7 +408,9 @@ attachments, create new maildirs, and so on.")
(version "0.3.7")
(source (origin
(method url-fetch)
- ; v0.3.7 not on PyPi yet, so use github instead
+ ;; package author intends on distributing via github rather
+ ;; than pypi:
+ ;; https://github.com/pazz/alot/issues/877#issuecomment-230173331
(uri (string-append "https://github.com/pazz/alot/archive/"
version ".tar.gz"))
(file-name (string-append "alot-" version ".tar.gz"))
@@ -418,8 +420,8 @@ attachments, create new maildirs, and so on.")
(build-system python-build-system)
(arguments
`(#:tests? #f ; no tests
- ; python 3 is unsupported, more info:
- ; https://github.com/pazz/alot/blob/0.3.7/docs/source/faq.rst
+ ;; python 3 is unsupported, more info:
+ ;; https://github.com/pazz/alot/blob/0.3.7/docs/source/faq.rst
#:python ,python-2))
(inputs
`(("python2-magic" ,python2-magic)