summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2021-11-11 10:30:05 -0500
committerLudovic Courtès <ludo@gnu.org>2021-11-12 23:58:32 +0100
commit337489478639db6177813b8966c68f8ce4be39d8 (patch)
tree0ce1c91d74f8b693ddb2e6d038cbbeeb8578ae8b /gnu/packages/mail.scm
parentd40234062552ed5f058410e6565ee231cb5bfe52 (diff)
downloadguix-patches-337489478639db6177813b8966c68f8ce4be39d8.tar
guix-patches-337489478639db6177813b8966c68f8ce4be39d8.tar.gz
gnu: Add rss2email.
* gnu/packages/mail.scm (rss2email): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b2d69e2064..04d4a91795 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2020 divoplade <d@divoplade.fr>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
+;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4564,3 +4565,41 @@ regexes, approximate regexes, a Hidden Markov Model, Orthogonal Sparse
Bigrams, WINNOW, Correlation, KNN/Hyperspace, or Bit Entropy (or by other
means--it's all programmable).")
(license license:gpl3)))
+
+(define-public rss2email
+ (package
+ (name "rss2email")
+ (version "3.13.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rss2email/rss2email")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g1yr3v3ibdh2jqil64fbdbplx5m2yzxr893fqfkwcc5c7fbwl4d"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "test"
+ ;; Skip networking tests
+ (substitute* "test.py"
+ (("( *)class (:?TestSend|TestFetch).*" match indent)
+ (string-append indent "@unittest.skip(\"Networking stuff skipped\")\n"
+ indent match)))
+ (invoke "python" "-m" "unittest"))))))))
+ (inputs
+ `(("python-feedparser" ,python-feedparser)
+ ("python-html2text" ,python-html2text)))
+ (home-page "https://github.com/rss2email/rss2email")
+ (synopsis "Converts RSS/Atom newsfeeds to email")
+ (description "The RSS2email program (@command{r2e}) fetches RSS/Atom news
+feeds, converts them into emails, and sends them.")
+ ;; GPL version 2 or 3. NOT 2+.
+ (license (list license:gpl2
+ license:gpl3))))