summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-29 01:10:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-29 16:56:40 +0200
commit6e488fb069f5d4d8397955cf7d36735d224943a6 (patch)
treed8c870fa41c9f4c11f7d0d9ae3d7daf1effcd8c9 /gnu/packages/mail.scm
parentdb686f0b34fc9f9957eba007db32ac3eaadeab28 (diff)
downloadguix-patches-6e488fb069f5d4d8397955cf7d36735d224943a6.tar
guix-patches-6e488fb069f5d4d8397955cf7d36735d224943a6.tar.gz
gnu: exim: Prepare for cross-compilation.
* gnu/packages/mail.scm (exim)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 9bdfae2501..d3c29b7b17 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1821,7 +1821,7 @@ delivery.")
("perl" ,perl)
("pkg-config" ,pkg-config)))
(arguments
- '(#:phases
+ `(#:phases
(modify-phases %standard-phases
(replace 'configure
;; We'd use #:make-flags but the top-level Makefile calls others
@@ -1883,7 +1883,7 @@ delivery.")
(substitute* "src/version.c"
(("#include \"cnumber.h\"") "1")))))
#:make-flags
- (list "CC=gcc"
+ (list (string-append "CC=" ,(cc-for-target))
"INSTALL_ARG=-no_chown")
;; No 'check' target. There is a test suite in test/, which assumes that
;; certain build options were (not) used and that it can freely ‘sudo’.