summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-03-23 22:04:55 +0000
committerLudovic Courtès <ludo@gnu.org>2024-06-18 11:42:19 +0200
commite8c3fb3f7ea6444b80467fef8c83efc8689a7faf (patch)
tree6fc3b0d9d76442f09903263b909ff2ad9d9abfdc /gnu/packages/machine-learning.scm
parentbec16cc91099a70bef0fc399cdd625b08db5bc8c (diff)
downloadguix-patches-e8c3fb3f7ea6444b80467fef8c83efc8689a7faf.tar
guix-patches-e8c3fb3f7ea6444b80467fef8c83efc8689a7faf.tar.gz
gnu: nnpack: Update to commit 70a77f4.
* gnu/packages/machine-learning.scm (nnpack): Update to commit 70a77f4. [supported-systems]: New field.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm21
1 files changed, 8 insertions, 13 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 7646572aa4..57efb1b1bd 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -3994,10 +3994,11 @@ reduction technique that can be used for visualization similarly to t-SNE, but
also for general non-linear dimension reduction.")
(license license:bsd-3)))
+;; Requires AVX2 on x86_64-linux.
(define-public nnpack
(let ((version "0.0")
- (commit "c07e3a0400713d546e0dea2d5466dd22ea389c73")
- (revision "1"))
+ (commit "70a77f485e8b934224f3a79efd8edcd84cd377b8")
+ (revision "2"))
(package
(name "nnpack")
(version (git-version version revision commit))
@@ -4008,19 +4009,11 @@ also for general non-linear dimension reduction.")
(file-name (git-file-name name version))
(sha256
(base32
- "0s0kk3a35w3yzf0q447p72350sbsh4qhg6vm3y2djbj4xpg7jc8v"))
+ "0c4pw926279s3rlx7mg4l4vhnfy6dh374n6w7zqhcn0bxpym1hv1"))
(patches (search-patches "nnpack-system-libraries.patch"))))
(build-system cmake-build-system)
- ;; XXX: The test suite runs but it's very expensive, and on x86_64 CPUs
- ;; that lack the right ISA extensions, tests fail with:
- ;;
- ;; Expected equality of these values:
- ;; nnp_status_success
- ;; Which is: 0
- ;; status
- ;; Which is: 51
- ;;
- ;; where 51 is 'nnp_status_unsupported_hardware'.
+ ;; XXX: The test suite runs but it's very expensive. On x86_64-linux, it
+ ;; requires AVX2 instructions.
(arguments '(#:tests? #f))
(synopsis "Acceleration package for neural network computations")
(description
@@ -4041,6 +4034,8 @@ and Darknet.")
googletest))
(native-inputs
(list python python-peachpy python-six))
+ ;; Supported for Linux.
+ (supported-systems '("x86_64-linux" "armhf-linux" "aarch64-linux"))
(license license:bsd-2))))
(define-public xnnpack