summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-03-23 22:05:01 +0000
committerLudovic Courtès <ludo@gnu.org>2024-06-18 11:44:25 +0200
commitb032109b5c522505bbadbec82499e9dadfdbc9e6 (patch)
tree39c7371b20d0f3ee5a52f360483c854bbfba8556 /gnu/packages/machine-learning.scm
parent3ef0b4e402c20c245040e773e466afbb5cdcdee3 (diff)
downloadguix-patches-b032109b5c522505bbadbec82499e9dadfdbc9e6.tar
guix-patches-b032109b5c522505bbadbec82499e9dadfdbc9e6.tar.gz
gnu: Add ideep-pytorch.
* gnu/packages/machine-learning.scm (ideep-pytorch): New variable.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index deb2974e2e..6c17481131 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -52,6 +52,7 @@
#:use-module (guix download)
#:use-module (guix svn-download)
#:use-module (guix build-system cmake)
+ #:use-module (guix build-system copy)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ocaml)
#:use-module (guix build-system pyproject)
@@ -4264,6 +4265,31 @@ API for loading and executing ONNX graphs on optimized backends. This package
contains facebook extensions and is used by PyTorch.")
(license license:expat))))
+(define-public ideep-pytorch
+ (package
+ (name "ideep-pytorch")
+ (version "3.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/intel/ideep")
+ (commit (string-append "pytorch-rls-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y6r938qryi3bnf15rp0fbilsfimdcgmvsa0ygwrn3zifw6386rb"))))
+ (build-system copy-build-system)
+ (arguments
+ (list
+ #:install-plan
+ ''(("include" "include"))))
+ (home-page "https://github.com/intel/ideep")
+ (synopsis "Ideep headers for interal use by PyTorch")
+ (description "This library is used internally as header-only library by
+PyTorch.")
+ (license license:expat)))
+
;; Please also update python-torchvision when updating this package.
(define-public python-pytorch
(package