summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorDavid Elsing <david.elsing@posteo.net>2024-03-23 22:05:07 +0000
committerLudovic Courtès <ludo@gnu.org>2024-06-18 11:45:15 +0200
commit4f50f86e41d4bd44a0c3ab832a8595633b5493d3 (patch)
treedc5a9c34c4a9e3290d3d3840f44904909037fd9f /gnu/packages/machine-learning.scm
parentd218d024ede876e328da34bf4a71d4738e495c17 (diff)
downloadguix-patches-4f50f86e41d4bd44a0c3ab832a8595633b5493d3.tar
guix-patches-4f50f86e41d4bd44a0c3ab832a8595633b5493d3.tar.gz
gnu: python-torchvision: Update to 0.17.1.
* gnu/packages/machine-learning.scm (python-torchvision): Update to 0.17.1. [source]: Add snippet to remove "android" and "ios" directories.
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 83fb8d4dc1..1456a53e1e 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -5200,7 +5200,7 @@ implementations and an easy-to-use API to create custom metrics. It offers:
(define-public python-torchvision
(package
(name "python-torchvision")
- (version "0.15.2")
+ (version "0.17.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -5210,7 +5210,12 @@ implementations and an easy-to-use API to create custom metrics. It offers:
(file-name (git-file-name name version))
(sha256
(base32
- "1cq2s13vkgg9rljjbrm4g33yxq7q5zqp7f4xm5cq624gvs0wxmi8"))))
+ "094jz0ryzh0yjxf687r61r482fdh3bax8ix2csghraps0z1sns1b"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "android")
+ (delete-file-recursively "ios")))))
(build-system pyproject-build-system)
(arguments
(list #:tests? #false)) ;the test suite is expensive and there is no easy