summaryrefslogtreecommitdiff
path: root/gnu/packages/machine-learning.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
committerLudovic Courtès <ludo@gnu.org>2017-03-09 16:35:41 +0100
commite90e0fad1b3ba79d81f02424e143ee6f4f736e8b (patch)
tree2c26190fd9114199b0ef79303e18a61100cab4af /gnu/packages/machine-learning.scm
parent8ea0700d231a8819fc7e8332e9685f0ce15c174e (diff)
parent9ec2a4d3fec44f08a55df9f5f3d1a04b83e7fcf6 (diff)
downloadguix-patches-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar
guix-patches-e90e0fad1b3ba79d81f02424e143ee6f4f736e8b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/machine-learning.scm')
-rw-r--r--gnu/packages/machine-learning.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 8f1f8ee53b..7bad833b38 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -504,20 +504,21 @@ and a QP solver.")
(define-public dlib
(package
(name "dlib")
- (version "19.1")
+ (version "19.3")
(source (origin
(method url-fetch)
(uri (string-append
"http://dlib.net/files/dlib-" version ".tar.bz2"))
(sha256
(base32
- "0p2pvcdalc6jhb6r99ybvjd9x74sclr0ngswdg9j2xl5pj7knbr4"))
+ "0gfy83av717qymv53yv7ki6mgh6mdw4xcxxbjk8lrs72f8qvnrcw"))
(modules '((guix build utils)))
(snippet
'(begin
;; Delete ~13MB of bundled dependencies.
(delete-file-recursively "dlib/external")
- (delete-file-recursively "docs/dlib/external")))))
+ (delete-file-recursively "docs/dlib/external")
+ #t))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -532,8 +533,7 @@ and a QP solver.")
(add-after 'disable-asserts 'disable-failing-tests
(lambda _
;; One test times out on MIPS, so we need to disable it.
- ;; The rest is known to fail on non-x86_64 platforms in the current release.
- ;; Some have been fixed in git; this list should be readjusted next update.
+ ;; Others are flaky on some platforms.
(let* ((system ,(or (%current-target-system)
(%current-system)))
(disabled-tests (cond
@@ -541,17 +541,16 @@ and a QP solver.")
'("object_detector" ; timeout
"data_io"))
((string-prefix? "armhf" system)
- '("learning_to_track" "max_cost_assignment"))
+ '("learning_to_track"))
((string-prefix? "i686" system)
- '("optimization" "matrix2" "mpc"))
+ '("optimization"))
(else '()))))
- ;; The following test fails due a bug in openblas < 0.2.18.
- (append! disabled-tests '("empirical_map"))
(for-each
(lambda (test)
(substitute* "dlib/test/makefile"
- (((string-append "SRC \\+= " test "\\.cpp")) "")) #t)
- disabled-tests))))
+ (((string-append "SRC \\+= " test "\\.cpp")) "")))
+ disabled-tests)
+ #t)))
(replace 'check
(lambda _
;; No test target, so we build and run the unit tests here.
@@ -562,7 +561,9 @@ and a QP solver.")
(zero? (system* "./dtest" "--runall")))))))
(add-after 'install 'delete-static-library
(lambda* (#:key outputs #:allow-other-keys)
- (delete-file (string-append (assoc-ref outputs "out") "/lib/libdlib.a")))))))
+ (delete-file (string-append (assoc-ref outputs "out")
+ "/lib/libdlib.a"))
+ #t)))))
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs