summaryrefslogtreecommitdiff
path: root/gnu/packages/lsof.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-28 16:24:46 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-28 16:24:46 +0200
commit284fa7264963acc5d114ef5d54c347126b1654ba (patch)
tree3e5360fcc81b6d0dce76a65aca60cf8528f2931f /gnu/packages/lsof.scm
parent12c9da35389dfba86ae0d863132a6b2c4374205a (diff)
parent882cacc1bb5be0df334dd7ce55b385a3a1678728 (diff)
downloadguix-patches-284fa7264963acc5d114ef5d54c347126b1654ba.tar
guix-patches-284fa7264963acc5d114ef5d54c347126b1654ba.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/lsof.scm')
-rw-r--r--gnu/packages/lsof.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/lsof.scm b/gnu/packages/lsof.scm
index 98bcdab468..5f413483f4 100644
--- a/gnu/packages/lsof.scm
+++ b/gnu/packages/lsof.scm
@@ -54,6 +54,9 @@
(replace 'configure
(lambda _
(setenv "LSOF_CC" ,(cc-for-target))
+ ,@(if (%current-target-system)
+ '((setenv "LINUX_CONF_CC" "gcc"))
+ '())
(setenv "LSOF_MAKE" "make")
;; By default, the makefile captures the output of 'uname -a'.