summaryrefslogtreecommitdiff
path: root/gnu/packages/logging.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 15:43:38 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 20:08:22 +0200
commit25e0083165dad410d85e92284c9746c6de959ea9 (patch)
treee2e9ed645877f38a01de47f6b9504ef576367a68 /gnu/packages/logging.scm
parent866ce9435176ac2909d81097b5f1d95c65e843c4 (diff)
downloadguix-patches-25e0083165dad410d85e92284c9746c6de959ea9.tar
guix-patches-25e0083165dad410d85e92284c9746c6de959ea9.tar.gz
gnu: spdlog: Update to 1.6.1.
* gnu/packages/logging.scm (spdlog): Update to 1.6.1. [arguments]: Add "-DSPDLOG_BUILD_TESTS=ON" in #:configure-flags.
Diffstat (limited to 'gnu/packages/logging.scm')
-rw-r--r--gnu/packages/logging.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/logging.scm b/gnu/packages/logging.scm
index 9139dc440e..c95eadd377 100644
--- a/gnu/packages/logging.scm
+++ b/gnu/packages/logging.scm
@@ -191,7 +191,7 @@ windows in a terminal, colorize, filter and merge.")
(define-public spdlog
(package
(name "spdlog")
- (version "1.5.0")
+ (version "1.6.1")
(source
(origin
(method git-fetch)
@@ -201,13 +201,14 @@ windows in a terminal, colorize, filter and merge.")
(file-name (git-file-name name version))
(sha256
(base32
- "0dn44r3xbw1w0bk9yflnxkh3rzdq2bpxkks44skfmqig0rsj1f1x"))))
+ "1b1b3zmbyjgqz5yfdgaasi55x03d37z7l2pasvgikx3mm1gabq5a"))))
(build-system cmake-build-system)
;; TODO run benchmark. Currently not possible, as adding
;; (gnu packages benchmark) forms a dependency cycle
(arguments
'(#:configure-flags
- (list "-DSPDLOG_BUILD_BENCH=OFF")))
+ (list "-DSPDLOG_BUILD_BENCH=OFF"
+ "-DSPDLOG_BUILD_TESTS=ON")))
(home-page "https://github.com/gabime/spdlog")
(synopsis "Fast C++ logging library")
(description "Spdlog is a very fast header-only/compiled C++ logging