summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-06-12 17:03:40 -0400
committerLudovic Courtès <ludo@gnu.org>2022-06-16 12:50:06 +0200
commit25809f5a40c1ef507a4af230c932d15ca4778859 (patch)
tree9ced4ae4d8f87df1b4b8cf5fac32ce679debfce2 /gnu/packages/llvm.scm
parent677ae314f6d8599980564ec69dfd3ff0111ef0b6 (diff)
downloadguix-patches-25809f5a40c1ef507a4af230c932d15ca4778859.tar
guix-patches-25809f5a40c1ef507a4af230c932d15ca4778859.tar.gz
gnu: Update llvm-for-rocm: Update to 5.1.3.
* gnu/packages/llvm.scm (llvm-for-rocm): Update to 5.1.3, now based on llvm-14. [source]{patches}: Remove unneeded patches (add_Object and add_libraries) and add new one (linkdl). * gnu/packages/patches/llvm-roc-3.0.0-add_libraries.patch, gnu/packages/patches/llvm-roc-4.2.0-add_Object.patch: Delete files. * gnu/packages/patches/llvm-roc-5.0.0-linkdl.patch: New file. * gnu/local.mk (dist_patch_DATA): Update to match current patches. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index c66714a097..7b197bb67b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
+;;; Copyright © 2022 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1109,10 +1110,10 @@ of programming tools as well as libraries with equivalent functionality.")
(define-public llvm-for-rocm
(package
- ;; Actually based on LLVM 13 as of v4.3, but llvm-12 works just fine.
- (inherit llvm-12)
+ ;; Based on LLVM 14 as of v5.0.0
+ (inherit llvm-14)
(name "llvm-for-rocm")
- (version "4.3.0") ;this must match '%rocm-version'
+ (version "5.1.3") ;this must match '%rocm-version'
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1121,10 +1122,9 @@ of programming tools as well as libraries with equivalent functionality.")
(file-name (git-file-name name version))
(sha256
(base32
- "0p75nr1qpmy6crymdax5hm40wkimman4lnglz4x5cnbiqindya7s"))
+ "0j6ydfkwrxwskgnhxc3cmry42n5faqbnwf2747qgf7lz5id8h8g5"))
(patches
- (search-patches "llvm-roc-4.2.0-add_Object.patch"
- "llvm-roc-3.0.0-add_libraries.patch"
+ (search-patches "llvm-roc-5.0.0-linkdl.patch"
"llvm-roc-4.0.0-remove-isystem-usr-include.patch"))))
(arguments
(substitute-keyword-arguments (package-arguments llvm-12)
@@ -1141,7 +1141,7 @@ of programming tools as well as libraries with equivalent functionality.")
"-DBUILD_SHARED_LIBS:BOOL=TRUE"
"-DLLVM_VERSION_SUFFIX="))))
(properties `((hidden? . #t)
- ,@(package-properties llvm-12)))))
+ ,@(package-properties llvm-14)))))