summaryrefslogtreecommitdiff
path: root/gnu/packages/llvm.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-12-31 14:10:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-12-31 14:10:25 +0200
commit23de2e1d5f8f7548e6f73085de23d9964774edbf (patch)
treefab69d4bb55f275f14012a724b7cb14bd307b57f /gnu/packages/llvm.scm
parentec6ba5c1fe9308cbc18f06c99adcfe0d13396a18 (diff)
parent1c27f72fc2770d68243dd95b7c05adc3b2b02ea4 (diff)
downloadguix-patches-23de2e1d5f8f7548e6f73085de23d9964774edbf.tar
guix-patches-23de2e1d5f8f7548e6f73085de23d9964774edbf.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates
Diffstat (limited to 'gnu/packages/llvm.scm')
-rw-r--r--gnu/packages/llvm.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 4702a342a0..b13a33ff1f 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -76,7 +76,7 @@
(setenv "LD_LIBRARY_PATH"
(string-append (getcwd) "/lib"))
#t)))))
- (home-page "http://www.llvm.org")
+ (home-page "https://www.llvm.org")
(synopsis "Optimizing compiler infrastructure")
(description
"LLVM is a compiler infrastructure designed for compile-time, link-time,
@@ -116,7 +116,7 @@ of programming tools as well as libraries with equivalent functionality.")
`(;; Don't use '-g' during the build to save space.
#:build-type "Release"
#:tests? #f)) ; Tests require gtest
- (home-page "http://compiler-rt.llvm.org")
+ (home-page "https://compiler-rt.llvm.org")
(synopsis "Runtime library for Clang/LLVM")
(description
"The \"clang-runtime\" library provides the implementations of run-time
@@ -125,7 +125,7 @@ and C++ source code to interface with the \"sanitization\" passes of the clang
compiler. In LLVM this library is called \"compiler-rt\".")
(license license:ncsa)
- ;; <http://compiler-rt.llvm.org/> doesn't list MIPS as supported.
+ ;; <https://compiler-rt.llvm.org/> doesn't list MIPS as supported.
(supported-systems (delete "mips64el-linux" %supported-systems))))
(define* (clang-from-llvm llvm clang-runtime hash
@@ -200,7 +200,7 @@ compiler. In LLVM this library is called \"compiler-rt\".")
(variable "LIBRARY_PATH")
(files '("lib" "lib64")))))
- (home-page "http://clang.llvm.org")
+ (home-page "https://clang.llvm.org")
(synopsis "C language family frontend for LLVM")
(description
"Clang is a compiler front end for the C, C++, Objective-C and