summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
committerAndreas Enge <andreas@enge.fr>2015-04-26 20:08:49 +0200
commit4ac0d6444d4edf38edc7c07331cf76deb4a506bc (patch)
tree5264c9c87172b8f0015823b0ee891d3672ac291a /gnu/packages/lisp.scm
parentd074e2f99130782e8eb7fa44c79c01db6c86f77d (diff)
parent7bde30e18de3e8cd7e4156ea5bb0d9439b6c12d7 (diff)
downloadguix-patches-4ac0d6444d4edf38edc7c07331cf76deb4a506bc.tar
guix-patches-4ac0d6444d4edf38edc7c07331cf76deb4a506bc.tar.gz
Merge branch 'master' into core-updates.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 8f12efb9eb..feaa08af38 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -343,9 +343,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(chdir (string-append
"lisp-kernel/"
,(match (or (%current-target-system) (%current-system))
- ("i686-linux" "linuxx8632")
+ ("i686-linux" "linuxx8632")
("x86_64-linux" "linuxx8664")
- ("armhf-linux" "linuxarm"))))
+ ("armhf-linux" "linuxarm")
+ ;; Prevent errors when querying this package
+ ;; on unsupported platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED"))))
(substitute* '("Makefile")
(("/bin/rm") "rm"))
(setenv "CC" "gcc")
@@ -366,9 +370,13 @@ statistical profiler, a code coverage tool, and many other extensions.")
(bash (assoc-ref inputs "bash"))
(kernel
,(match (or (%current-target-system) (%current-system))
- ("i686-linux" "lx86cl")
+ ("i686-linux" "lx86cl")
("x86_64-linux" "lx86cl64")
- ("armhf-linux" "armcl")))
+ ("armhf-linux" "armcl")
+ ;; Prevent errors when querying this package
+ ;; on unsupported platforms, e.g. when running
+ ;; "guix package --search="
+ (_ "UNSUPPORTED")))
(heap (string-append kernel ".image")))
(mkdir-p libdir)
(mkdir-p bindir)