summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-05-26 17:11:20 +0200
committerLudovic Courtès <ludo@gnu.org>2022-05-26 17:11:20 +0200
commit7097e98586df3110b80943a88c27804d65f214fa (patch)
tree2e244b9fc19acc569d6abd42306aaf013f02da0d /gnu/packages/lisp.scm
parent15870cc08d20501e3526fa892111a43ae9e3e02f (diff)
parent4577f3c6b60ea100e521c246fb169d6c05214b20 (diff)
downloadguix-patches-7097e98586df3110b80943a88c27804d65f214fa.tar
guix-patches-7097e98586df3110b80943a88c27804d65f214fa.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm12
1 files changed, 12 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d5f1e94269..ca85cab2b9 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -464,6 +464,18 @@ an interpreter, a compiler, a debugger, and much more.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (add-after 'unpack 'fix-build-id
+ ;; One of the build scripts makes a build id using the current date.
+ ;; Replace it with a reproducible id using a part of the output hash.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((hash (substring (assoc-ref outputs "out")
+ (+ (string-length (%store-directory)) 1)
+ (+ (string-length (%store-directory)) 9))))
+ (substitute* "make-config.sh"
+ (("echo .* > output/build-id.inc")
+ (string-append "echo '\"'guix-sbcl-"
+ hash
+ "'\"' > output/build-id.inc"))))))
(add-after 'unpack 'replace-asdf
;; SBCL developers have not committed to keeping ASDF up to date
;; due to breaking changes [1]. Guix can handle this situation