summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorKatherine Cox-Buday <cox.katherine.e@gmail.com>2019-03-29 15:06:03 -0500
committer宋文武 <iyzsong@member.fsf.org>2019-04-07 11:23:14 +0800
commit47a8aaa810c0adc7a1e344c5ba0789337232fde9 (patch)
treef9b2b03d343e189e013d78f607c000562ae8404e /gnu/packages/lisp.scm
parent155fc4369570b0c302f0a015b00d4462a1d3d3b5 (diff)
downloadguix-patches-47a8aaa810c0adc7a1e344c5ba0789337232fde9.tar
guix-patches-47a8aaa810c0adc7a1e344c5ba0789337232fde9.tar.gz
gnu: Add trivial-types.
* gnu/packages/lisp.scm (sbcl-trivial-types, cl-trivial-types): New variables. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 579a423c11..39adb6e054 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -4201,3 +4201,27 @@ connections (keep-alive), and SSL.")
(define-public cl-hunchentoot
(sbcl-package->cl-source-package sbcl-hunchentoot))
+
+(define-public sbcl-trivial-types
+ (package
+ (name "sbcl-trivial-types")
+ (version "0.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/m2ym/trivial-types.git")
+ (commit "ee869f2b7504d8aa9a74403641a5b42b16f47d88")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s4cp9bdlbn8447q7w7f1wkgwrbvfzp20mgs307l5pxvdslin341"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/m2ym/trivial-types")
+ (synopsis "Trivial type definitions for Common Lisp")
+ (description
+ "TRIVIAL-TYPES provides missing but important type definitions such as
+PROPER-LIST, ASSOCIATION-LIST, PROPERTY-LIST and TUPLE.")
+ (license license:llgpl)))
+
+(define-public cl-trivial-types
+ (sbcl-package->cl-source-package sbcl-trivial-types))