summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-05-30 16:42:27 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-06-07 09:35:40 +0200
commit2252f0553d990c551885380f0d4db729c7711b96 (patch)
treed2615066087e426b290041d36d0b8a00ef9dbb05 /gnu/packages/lisp-xyz.scm
parent75141b782acaea39a5bf2c044d7a4fe01e0c32ff (diff)
downloadguix-patches-2252f0553d990c551885380f0d4db729c7711b96.tar
guix-patches-2252f0553d990c551885380f0d4db729c7711b96.tar.gz
gnu: cl-fset: Update to 1.3.3-1.a75a4ec.
* gnu/packages/lisp-xyz.scm (sbcl-fset): Update to 1.3.3-1.a75a4ec. [arguments]: Add 'fix-build' phase. Change-Id: I9f0947e64c81b1547d657c721879d1e12c2507d3
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 5b888eafb6..90676ad4db 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -15652,28 +15652,35 @@ of the files and the line numbers where they were found.")
(sbcl-package->ecl-package sbcl-formgrep))
(define-public sbcl-fset
- (let ((commit "6d2f9ded8934d2b42f2571a0ba5bda091037d852")
+ (let ((commit "a75a4ec713277780d9e15bfaa486b56949142d35")
(revision "1"))
(package
(name "sbcl-fset")
- (version (git-version "1.3.2" revision commit))
+ (version (git-version "1.3.3" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/slburson/fset")
(commit commit)))
- (file-name (git-file-name name version))
+ (file-name (git-file-name "cl-fset" version))
(sha256
- (base32
- "127acblwrbqicx47h6sgvknz1cqyfn8p4xkhkn1m7hxh8w5gk1zy"))
+ (base32 "0bah0z8zrcykvnbi2wcdlbx902r818xg5dvd3384wf75kr2ccxvv"))
(snippet '(begin
;; Remove obsolete copy of system definition.
- (delete-file "Code/fset.asd")
- #t))))
+ (delete-file "Code/fset.asd")))))
(build-system asdf-build-system/sbcl)
(inputs
(list sbcl-misc-extensions sbcl-mt19937 sbcl-named-readtables))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build
+ (lambda _
+ ;; Fix for SBCL > 2.4.4
+ (substitute* "Code/port.lisp"
+ (("sb-ext::once-only")
+ "sb-int:once-only")))))))
(synopsis "Functional set-theoretic collections library")
(description
"FSet is a functional set-theoretic collections library for Common Lisp.