summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2022-04-13 08:20:02 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2022-04-13 13:42:35 +0200
commit499610418979a42293374832f14a77777b97517d (patch)
treece1e703d6450211714919c817dd9bfa9e32d98bf /gnu/packages/lisp-xyz.scm
parentfc89b50b7bb2edbc38b20adf8c899934dedcb6c3 (diff)
downloadguix-patches-499610418979a42293374832f14a77777b97517d.tar
guix-patches-499610418979a42293374832f14a77777b97517d.tar.gz
gnu: Add cl-simple-routes.
* gnu/packages/lisp-xyz.scm (cl-simple-routes, ecl-simple-routes, sbcl-simple-routes): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 75b299152a..29b3a10d98 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -20876,6 +20876,38 @@ Lisp.")
(define-public ecl-jzon
(sbcl-package->ecl-package sbcl-jzon))
+(define-public sbcl-simple-routes
+ (let ((commit "6f88c38945a4de73e85786d3499c39cacb400598")
+ (revision "1"))
+ (package
+ (name "sbcl-simple-routes")
+ (version (git-version "0.3" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/vancan1ty/simple-routes")
+ (commit commit)))
+ (file-name (git-file-name "cl-simple-routes" version))
+ (sha256
+ (base32 "0zkjl69zf1ynmqmvwccdbip3wxfyi7xplivv70qwxzd27mc0kh3k"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ (list sbcl-cl-ppcre
+ sbcl-hunchentoot))
+ (home-page "https://gitlab.com/vancan1ty/simple-routes")
+ (synopsis "URL routing library for Hunchentoot")
+ (description
+ "@code{simple-routes} is a simple Common Lisp RESTful routing facility
+on top of Hunchentoot.")
+ (license license:bsd-2))))
+
+(define-public cl-simple-routes
+ (sbcl-package->cl-source-package sbcl-simple-routes))
+
+(define-public ecl-simple-routes
+ (sbcl-package->ecl-package sbcl-simple-routes))
+
(define-public sbcl-purgatory
(let ((commit "ade0d60a14a1067b9cc8cf06d1f1a1ca8cecdb03")
(revision "1"))