summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-01-25 18:03:31 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-01-26 09:31:40 +0100
commitf39d8d2ca96b15c4d415a36932526e1dd9ee212c (patch)
tree22a00f7618a312431465d7a453370876627abc5b /gnu/packages/lisp-xyz.scm
parentcf31ee0427ad9ac254a7fc2af9a4599d44c22f97 (diff)
downloadguix-patches-f39d8d2ca96b15c4d415a36932526e1dd9ee212c.tar
guix-patches-f39d8d2ca96b15c4d415a36932526e1dd9ee212c.tar.gz
gnu: Add cl-modularize.
* gnu/packages/lisp-xyz.scm (cl-modularize, ecl-modularize, sbcl-modularize): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3fefccf1e8..02621260dd 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -9686,6 +9686,46 @@ PascalCase, snake_case, param-case, CONSTANT_CASE and more.")
(define-public ecl-cl-change-case
(sbcl-package->ecl-package sbcl-cl-change-case))
+(define-public sbcl-modularize
+ (let ((commit "86c5d9a11fbd2df9f0f03ac10b5d71837c8934ba")
+ (revision "1"))
+ (package
+ (name "sbcl-modularize")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Shinmera/modularize")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1zys29rfkb649rkgl3snxhajk8d5yf7ryxkrwy020kwdh7zdsg7d"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:test-asd-file "modularize-test-module.asd"
+ #:asd-files '("modularize.asd" "modularize-test-module.asd")
+ #:asd-systems '("modularize" "modularize-test-module")))
+ (inputs
+ `(("documentation-utils" ,sbcl-documentation-utils)
+ ("trivial-package-local-nicknames" ,sbcl-trivial-package-local-nicknames)))
+ (home-page "https://shinmera.github.io/modularize/")
+ (synopsis "Common Lisp modularization framework")
+ (description
+ "@code{MODULARIZE} is an attempt at providing a common interface to
+segregate major application components. This is achieved by adding special
+treatment to packages. Each module is a package that is specially registered,
+which allows it to interact and co-exist with other modules in better ways. For
+instance, by adding module definition options you can introduce mechanisms to
+tie modules together in functionality, hook into each other and so on.")
+ (license license:zlib))))
+
+(define-public ecl-modularize
+ (sbcl-package->ecl-package sbcl-modularize))
+
+(define-public cl-modularize
+ (sbcl-package->cl-source-package sbcl-modularize))
+
(define-public sbcl-moptilities
(let ((commit "a436f16b357c96b82397ec018ea469574c10dd41"))
(package