summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-02-04 01:32:23 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-02-04 14:07:30 +0100
commit68608dd412c49a3372567b2d43633d9c7161ecbb (patch)
tree2c9e4c3982c6733f30079544212e9d15e2b54486 /gnu/packages/lisp-xyz.scm
parenta1b3c6be4cdc16986f879f4757c868dbd0fa5b6e (diff)
downloadguix-patches-68608dd412c49a3372567b2d43633d9c7161ecbb.tar
guix-patches-68608dd412c49a3372567b2d43633d9c7161ecbb.tar.gz
gnu: Add cl-specialization-store.
* gnu/packages/lisp-xyz.scm (cl-specialization-store, ecl-specialization-store, sbcl-specialization-store): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index bc607f2e54..9c8bf0a548 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6693,6 +6693,45 @@ ability to store all Common Lisp data types into streams.")
(define-public ecl-cl-store
(sbcl-package->ecl-package sbcl-cl-store))
+(define-public sbcl-specialization-store
+ (let ((commit "8d39a866a6f24986aad3cc52349e9cb2653496f3")
+ (revision "1"))
+ (package
+ (name "sbcl-specialization-store")
+ (version (git-version "0.0.5" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/markcox80/specialization-store")
+ (commit commit)))
+ (file-name (git-file-name "specialization-store" version))
+ (sha256
+ (base32 "0r0bgb46q4gy72l78s7djkxq8ibb4bb3yh9brsry5lih7br8lhi0"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (inputs
+ `(("alexandria" ,sbcl-alexandria)
+ ("introspect-environment" ,sbcl-introspect-environment)))
+ (home-page "https://github.com/markcox80/specialization-store")
+ (synopsis "Different type of generic function for Common Lisp")
+ (description
+ "SPECIALIZATION-STORE system provides a new kind of function, called
+a store function, whose behavior depends on the types of objects passed to the
+function.")
+ (license license:bsd-2))))
+
+(define-public ecl-specialization-store
+ (package
+ (inherit (sbcl-package->ecl-package sbcl-specialization-store))
+ (arguments
+ ;; TODO: Find why the tests get stuck forever; disable them for now.
+ `(#:tests? #f))))
+
+(define-public cl-specialization-store
+ (sbcl-package->cl-source-package sbcl-specialization-store))
+
(define-public sbcl-cl-gobject-introspection
(let ((commit "d0136c8d9ade2560123af1fc55bbf70d2e3db539")
(revision "1"))