summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-12-01 15:15:52 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-12-01 15:15:52 +0100
commitc16628ea6e7a37cd324a40637074311473d9f3b2 (patch)
tree29ac8abe30cba71f85f98b45c01990e4a9e2b394 /gnu/packages/lisp-xyz.scm
parent1467ae640ae37ca9bbc825cc6c7b46fcb9585673 (diff)
downloadguix-patches-c16628ea6e7a37cd324a40637074311473d9f3b2.tar
guix-patches-c16628ea6e7a37cd324a40637074311473d9f3b2.tar.gz
gnu: Add glyphs.
* gnu/packages/lisp-xyz.scm (cl-glyphs, ecl-glyphs, sbcl-glyphs): New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index d62ecb6b18..2bfd1e75f0 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12303,3 +12303,35 @@ even by adding additional statistical @code{compute}ations. ")
(define-public ecl-trivial-benchmark
(sbcl-package->ecl-package sbcl-trivial-benchmark))
+
+(define-public sbcl-glyphs
+ (let ((commit "1ff5714e8c1dca327bc604dfe3e3d1f4b7755373"))
+ (package
+ (name "sbcl-glyphs")
+ (version (git-version "0.0.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ahungry/glyphs/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17kai1anbkk5dj5sbrsin2fc019cmcbglb900db60v38myj0y0wf"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("parenscript" ,sbcl-parenscript)
+ ("named-readtables" ,sbcl-named-readtables)))
+ (home-page "https://github.com/ahungry/glyphs/")
+ (synopsis "Reduce Common Lisp verbosity")
+ (description
+ "This library is a little experiment in reducing verbosity in Common
+Lisp, inspired by BODOL (@url{https://github.com/bodil/BODOL}).")
+ (license license:gpl3))))
+
+(define-public cl-glyphs
+ (sbcl-package->cl-source-package sbcl-glyphs))
+
+(define-public ecl-glyphs
+ (sbcl-package->ecl-package sbcl-glyphs))