summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-12-01 12:36:11 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2020-12-01 12:38:47 +0100
commit91d59549a7c9bfe3c458b68f9cd072c5e7853c0e (patch)
treeb21cfe9bc1e59459279d4201646e35d50bc145e1 /gnu/packages/lisp-xyz.scm
parentf825720743a88a4a1126e8f60f7287876ad0840d (diff)
downloadguix-patches-91d59549a7c9bfe3c458b68f9cd072c5e7853c0e.tar
guix-patches-91d59549a7c9bfe3c458b68f9cd072c5e7853c0e.tar.gz
gnu: Add trivial-shell.
* gnu/packages/lisp-xyz.scm (cl-trivial-shell, ecl-trivial-shell, sbcl-trivial-shell): New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 511ef8b395..3b85054d0e 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -12011,3 +12011,33 @@ not so easy to copy (ssyntax, argument destructuring, etc.).")
(define-public ecl-clamp
(sbcl-package->ecl-package sbcl-clamp))
+
+(define-public sbcl-trivial-shell
+ (let ((commit "e02ec191b34b52deca5d1c4ee99d4fa13b8772e0"))
+ (package
+ (name "sbcl-trivial-shell")
+ (version (git-version "0.2.0" "1" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gwkkwg/trivial-shell")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08mpkl5ij5sjfsyn8pq2kvsvpvyvr7ha1r8g1224fa667b8k2q85"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("lift" ,sbcl-lift)))
+ (home-page "http://common-lisp.net/project/trivial-shell/")
+ (synopsis "Common Lisp access to the shell")
+ (description
+ "A simple Common-Lisp interface to the underlying operating system.
+It's independent of the implementation and operating system.")
+ (license license:expat))))
+
+(define-public cl-trivial-shell
+ (sbcl-package->cl-source-package sbcl-trivial-shell))
+
+(define-public ecl-trivial-shell
+ (sbcl-package->ecl-package sbcl-trivial-shell))