summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2020-12-26 23:56:07 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2020-12-28 14:31:17 +0100
commit14efb2f8ebd641fc3a9ee2ad802591e87dd4131a (patch)
treecd29af93183afe741cf68e68f061e8c5b1ed37c9 /gnu/packages/lisp-xyz.scm
parent3742c7f6dc0e9e7e2bf9375f063f1439361a7137 (diff)
downloadguix-patches-14efb2f8ebd641fc3a9ee2ad802591e87dd4131a.tar
guix-patches-14efb2f8ebd641fc3a9ee2ad802591e87dd4131a.tar.gz
gnu: Add cl-uax-15.
* gnu/packages/lisp-xyz.scm (cl-uax-15, ecl-uax-15, sbcl-uax-15): New variables. Co-authored-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 885c4010a0..c9f3794c19 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -455,6 +455,41 @@ compatible with ANSI-compliant Common Lisp implementations.")
(define-public ecl-cl-ppcre
(sbcl-package->ecl-package sbcl-cl-ppcre))
+(define-public sbcl-uax-15
+ (let ((commit "e7439a91b72f533fcf736643e3ff0677b56c2e7d")
+ (revision "1"))
+ (package
+ (name "sbcl-uax-15")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sabracrolleton/uax-15")
+ (commit commit)))
+ (file-name (git-file-name "uax-15" version))
+ (sha256
+ (base32 "1vf8a2aikgx0l5bsq0z9s0dw3sgx1887xhagdlf66fwffa5jskg6"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (inputs
+ `(("cl-ppcre" ,sbcl-cl-ppcre)
+ ("split-sequence" ,sbcl-split-sequence)))
+ (arguments
+ `(#:asd-systems '("uax-15")))
+ (home-page "https://github.com/sabracrolleton/uax-15")
+ (synopsis "Common Lisp implementation of unicode normalization functions")
+ (description "This package provides supports for unicode normalization,
+RFC8264 and RFC7564.")
+ (license license:expat))))
+
+(define-public cl-uax-15
+ (sbcl-package->cl-source-package sbcl-uax-15))
+
+(define-public ecl-uax-15
+ (sbcl-package->ecl-package sbcl-uax-15))
+
(define-public sbcl-cl-unicode
(package
(name "sbcl-cl-unicode")