summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2021-11-29 20:28:03 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-12-01 09:44:03 +0100
commit4beb013c84cd44a2e6dc03a2697615c660985f4a (patch)
treeb7c9f2ba27b9d77285ffaf6a8fe31466b8578ff5 /gnu/packages/lisp-xyz.scm
parentd7477f09c3e907024297d0640dff3f22a49a59ec (diff)
downloadguix-patches-4beb013c84cd44a2e6dc03a2697615c660985f4a.tar
guix-patches-4beb013c84cd44a2e6dc03a2697615c660985f4a.tar.gz
gnu: Add cl-liballegro.
* gnu/packages/lisp-xyz.scm: (sbcl-cl-liballegro, ecl-cl-liballegro, cl-liballegro): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 6ddc13e951..5d35da05d4 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -69,6 +69,7 @@
#:use-module (gnu packages file)
#:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages game-development)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
@@ -17742,6 +17743,51 @@ fit together as required by any particular game.")
(define-public cl-trial
(sbcl-package->cl-source-package sbcl-trial))
+(define-public sbcl-cl-liballegro
+ (let ((commit "49f632ce97fc4f835bf5d450588793234b980a64")
+ (revision "1"))
+ (package
+ (name "sbcl-cl-liballegro")
+ (version (git-version "0.2.15" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/resttime/cl-liballegro")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0brbr7i342s0gadlnzd3a61w2b9ihhx60l19ararnc2asvyhmz7x"))))
+ (build-system asdf-build-system/sbcl)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-allegro-lib-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((allegro-lib-path (string-append
+ (assoc-ref inputs "allegro") "/lib/")))
+ (substitute* "src/library.lisp"
+ (("lib \".so\"" all)
+ (string-append "\"" allegro-lib-path "\"" " lib \".so\"")))))))))
+ (inputs
+ `(("allegro" ,allegro)
+ ("cffi" ,sbcl-cffi)
+ ("float-features" ,sbcl-float-features)
+ ("trivial-garbage" ,sbcl-trivial-garbage)
+ ("trivial-main-thread" ,sbcl-trivial-main-thread)))
+ (home-page "https://github.com/resttime/cl-liballegro")
+ (synopsis "Allegro 5 game programming library bindings for Common Lisp")
+ (description
+ "This package provides CFFI bindings and interface to Allegro 5 game
+developing library for Common Lisp.")
+ (license license:zlib))))
+
+(define-public ecl-cl-liballegro
+ (sbcl-package->ecl-package sbcl-cl-liballegro))
+
+(define-public cl-liballegro
+ (sbcl-package->cl-source-package sbcl-cl-liballegro))
+
(define-public sbcl-alloy
(let ((commit "e86e22c2887836ec31cd97e039f0bca5248d8f1c")
(revision "1"))