summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2021-03-02 13:32:03 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2021-03-02 13:38:37 +0100
commit8664eede1af88b810139800d75892dba0f4f576a (patch)
tree379194a922c8ab034cb0f8359e2102402052f869 /gnu/packages/lisp-xyz.scm
parent4a9cb7a46f693f5e1c0e1b88b3b4c2f716dd63b2 (diff)
downloadguix-patches-8664eede1af88b810139800d75892dba0f4f576a.tar
guix-patches-8664eede1af88b810139800d75892dba0f4f576a.tar.gz
gnu: sbcl-hu.dwim.common-lisp: Update to 2021-01-27.
* gnu/packages/lisp-xyz.scm (sbcl-hu.dwim.common-lisp): Update to 2021-01-27. [source]: Use new GitHub repository. [home-page]: Use full address.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm40
1 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b4b65b9c45..2de0461a9b 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -11977,27 +11977,27 @@ overview article about COP which also contains some ContextL examples:
(sbcl-package->ecl-package sbcl-contextl))
(define-public sbcl-hu.dwim.common-lisp
- (package
- (name "sbcl-hu.dwim.common-lisp")
- (version "2015-07-09")
- (source
- (origin
- (method url-fetch)
- (uri (string-append
- "http://beta.quicklisp.org/archive/hu.dwim.common-lisp/"
- version "/hu.dwim.common-lisp-"
- (string-replace-substring version "-" "")
- "-darcs.tgz"))
- (sha256
- (base32 "13cxrvh55rw080mvfir7s7k735l9rcfh3khxp97qfwd5rz0gadb9"))))
- (build-system asdf-build-system/sbcl)
- (native-inputs
- `(("hu.dwim.asdf" ,sbcl-hu.dwim.asdf)))
- (home-page "http://dwim.hu/")
- (synopsis "Redefine some standard Common Lisp names")
- (description "This library is a redefinition of the standard Common Lisp
+ (let ((commit "90558195773383142a57a16687d5e7f4adea6418"))
+ (package
+ (name "sbcl-hu.dwim.common-lisp")
+ (version "2021-01-27")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hu-dwim/hu.dwim.common-lisp/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06zkdw3scnaw0d4nmsgkv7pi7sw00dikdgfgsqmbqfbz2yrsdabk"))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("hu.dwim.asdf" ,sbcl-hu.dwim.asdf)))
+ (home-page "http://dwim.hu/project/hu.dwim.common-lisp")
+ (synopsis "Redefine some standard Common Lisp names")
+ (description "This library is a redefinition of the standard Common Lisp
package that includes a number of renames and shadows. ")
- (license license:public-domain)))
+ (license license:public-domain))))
(define-public cl-hu.dwim.common-lisp
(sbcl-package->cl-source-package sbcl-hu.dwim.common-lisp))