summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorcage <cage-dev@twistfold.it>2021-05-08 19:40:15 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-12-01 13:26:29 +0100
commit8e7e839c98102a79b5804b39e3cfb58e94687d97 (patch)
treefdc56d03a20ae1bb1dc8d324bfbb5351bfb0ebe8 /gnu/packages/lisp-xyz.scm
parent0da9ae01a88978d6e446a8092e8ca970fd1ed8c4 (diff)
downloadguix-patches-8e7e839c98102a79b5804b39e3cfb58e94687d97.tar
guix-patches-8e7e839c98102a79b5804b39e3cfb58e94687d97.tar.gz
gnu: cl-unix-opts: Update to 0.1.7-1.0e61f34.
* gnu/packages/lisp-xyz.scm (sbcl-unix-opts): Update to 0.1.7-1.0e61f34. [source]: Fetch using commit instead of old tag. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm39
1 files changed, 20 insertions, 19 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 3cd52d4534..1405e91e05 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -3056,31 +3056,32 @@ settings ensure a very simple mode of operation, similar to that provided by
(sbcl-package->ecl-package sbcl-cl-json))
(define-public sbcl-unix-opts
- (package
- (name "sbcl-unix-opts")
- (version "0.1.7")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/libre-man/unix-opts")
- (commit version)))
- (file-name (git-file-name "unix-opts" version))
- (sha256
- (base32
- "08djdi1ard09fijb7w9bdmhmwd98b1hzmcnjw9fqjiqa0g3b44rr"))))
- (build-system asdf-build-system/sbcl)
- (home-page "https://github.com/hankhero/cl-json")
- (synopsis "Unix-style command line options parser")
- (description
- "This is a minimalistic parser of command line options. The main
+ (let ((commit "0e61f34b2ecf62288437810d4abb31e572048b04")
+ (revision "1"))
+ (package
+ (name "sbcl-unix-opts")
+ (version (git-version "0.1.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libre-man/unix-opts")
+ (commit commit)))
+ (file-name (git-file-name "unix-opts" version))
+ (sha256
+ (base32 "16mcqpzwrz808p9n3wwl99ckg3hg7yihw08y1i4l7c92aldbkasq"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/hankhero/cl-json")
+ (synopsis "Unix-style command line options parser")
+ (description
+ "This is a minimalistic parser of command line options. The main
advantage of the library is the ability to concisely define command line
options once and then use this definition for parsing and extraction of
command line arguments, as well as printing description of command line
options (you get --help for free). This way you don't need to repeat
yourself. Also, @command{unix-opts} doesn't depend on anything and
precisely controls the behavior of the parser via Common Lisp restarts.")
- (license license:expat)))
+ (license license:expat))))
(define-public cl-unix-opts
(sbcl-package->cl-source-package sbcl-unix-opts))