summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-09-16 11:03:31 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-09-16 11:03:31 +0200
commitbdd3b1b23257b6ae3a0a3ce9330265f45352dd1f (patch)
tree0ee9799d182a804d19e4298000057c3e98255186 /gnu/packages/lisp-xyz.scm
parente0d9103f416d5c6e6c0c230f08dc9392bb8e8df1 (diff)
downloadguix-patches-bdd3b1b23257b6ae3a0a3ce9330265f45352dd1f.tar
guix-patches-bdd3b1b23257b6ae3a0a3ce9330265f45352dd1f.tar.gz
gnu: Add some missing ECL packages.
* gnu/packages/lisp-xyz.scm (ecl-hunchentoot, ecl-clack, ecl-fset, ecl-clsql): New variables.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b13482e070..66d99b87f7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages webkit)
#:use-module (gnu packages xdisorg)
#:use-module (ice-9 match)
+ #:use-module (srfi srfi-1)
#:use-module (srfi srfi-19))
(define-public sbcl-alexandria
@@ -3313,6 +3314,13 @@ connections (keep-alive), and SSL.")
(define-public cl-hunchentoot
(sbcl-package->cl-source-package sbcl-hunchentoot))
+(define-public ecl-hunchentoot
+ (package
+ (inherit (sbcl-package->ecl-package sbcl-hunchentoot))
+ (arguments
+ ;; Tests fail on ECL with 'Socket error in "socket": EINVAL'.
+ '(#:tests? #f))))
+
(define-public sbcl-trivial-types
(package
(name "sbcl-trivial-types")
@@ -4201,6 +4209,9 @@ Python's WSGI and Ruby's Rack.")
(define-public cl-clack
(sbcl-package->cl-source-package sbcl-clack))
+(define-public ecl-clack
+ (sbcl-package->ecl-package sbcl-clack))
+
(define-public sbcl-log4cl
(let ((commit "611e094458504b938d49de904eab141285328c7c")
(revision "1"))
@@ -7292,6 +7303,13 @@ may contain sets, maps may be keyed by sets, etc.")
(define-public cl-fset
(sbcl-package->cl-source-package sbcl-fset))
+(define-public ecl-fset
+ (package
+ (inherit (sbcl-package->ecl-package sbcl-fset))
+ (arguments
+ ;; Tests fails on ECL with "The function FSET::MAKE-CHAR is undefined".
+ '(#:tests? #f))))
+
(define-public sbcl-cl-cont
(let ((commit "fc1fa7e6eb64894fdca13e688e6015fad5290d2a")
(revision "1"))
@@ -8909,6 +8927,17 @@ interfaces as well as a functional and an object oriented interface.")
(make-file-writable "doc/html.tar.gz")
#t)))))))
+(define-public ecl-clsql
+ (let ((pkg (sbcl-package->ecl-package sbcl-clsql)))
+ (package
+ (inherit pkg)
+ (inputs
+ (alist-delete "uffi" (package-inputs pkg)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments pkg)
+ ((#:asd-files asd-files '())
+ `(cons "clsql-cffi.asd" ,asd-files)))))))
+
(define-public sbcl-sycamore
(let ((commit "fd2820fec165ad514493426dea209728f64e6d18"))
(package