summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-11-01 10:21:55 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-01 10:58:12 +0100
commit9070bfd2c043258718e4fe444a0f8a4aa4589f37 (patch)
treee43a2400235d8f89fa43a77eab1567b08a20f17b /gnu/packages/lisp-xyz.scm
parent840a70808844233d1b372c283ba19037a4dc87d2 (diff)
downloadguix-patches-9070bfd2c043258718e4fe444a0f8a4aa4589f37.tar
guix-patches-9070bfd2c043258718e4fe444a0f8a4aa4589f37.tar.gz
gnu: cl-string-match: Fix dependency.
* gnu/packages/lisp-xyz.scm (sbcl-cl-string-match)[arguments]: Add 'fix-dependency' phase. [source, home-page]: Update to new URL.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index b1222271a4..13d585eae3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -2472,7 +2472,7 @@ values from a string in Common Lisp.")
(origin
(method hg-fetch)
(uri (hg-reference
- (url "https://bitbucket.org/vityok/cl-string-match/")
+ (url "https://github.com/vityok/cl-string-match")
(changeset changeset)))
(sha256
(base32
@@ -2494,13 +2494,20 @@ values from a string in Common Lisp.")
;; For testing:
`(("lisp-unit" ,sbcl-lisp-unit)))
(arguments
- `(#:tests? #f))
+ `(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-dependency
+ (lambda _
+ (substitute* "cl-string-match.asd"
+ ((":mgl-pax")
+ ":mgl-pax/document")))))))
(synopsis "Set of utilities to manipulate strings in Common Lisp")
(description
"@command{cl-strings} is a small, portable, dependency-free set of
utilities that make it even easier to manipulate text in Common Lisp. It has
100% test coverage and works at least on sbcl, ecl, ccl, abcl and clisp.")
- (home-page "https://bitbucket.org/vityok/cl-string-match/")
+ (home-page "https://github.com/vityok/cl-string-match")
(license license:bsd-3))))
(define-public cl-string-match