summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-17 05:43:10 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-19 10:48:42 +0100
commit03b146c45c5fe673eca6e423a860a0d4470d2109 (patch)
tree96c1fb1964815fe5f356dd63c3501d275e479638 /gnu/packages/lisp-xyz.scm
parentdf1e97a644ba30a743de64deed4486621b9b5403 (diff)
downloadguix-patches-03b146c45c5fe673eca6e423a860a0d4470d2109.tar
guix-patches-03b146c45c5fe673eca6e423a860a0d4470d2109.tar.gz
gnu: Add cl-trivial-open-browser.
* gnu/packages/lisp-xyz.scm (cl-trivial-open-browser, ecl-trivial-open-browser, sbcl-trivial-open-browser): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 33eec1694b..ad78f6a6b7 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18860,6 +18860,34 @@ higher-level lispier interface.")
(define-public ecl-cl-charms
(sbcl-package->ecl-package sbcl-cl-charms))
+(define-public sbcl-trivial-open-browser
+ (let ((commit "7ab4743dea9d592639f15c565bfa0756e828c427")
+ (revision "1"))
+ (package
+ (name "sbcl-trivial-open-browser")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eudoxia0/trivial-open-browser")
+ (commit commit)))
+ (file-name (git-file-name "trivial-open-browser" version))
+ (sha256
+ (base32 "0ixay1piq420i6adx642qhw45l6ik7rvgk52lyz27dvx5f8yqsdb"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/eudoxia0/trivial-open-browser")
+ (synopsis "Open a browser window from Common Lisp")
+ (description
+ "This package provides a library to open a web browser to a URL.")
+ (license license:expat))))
+
+(define-public cl-trivial-open-browser
+ (sbcl-package->cl-source-package sbcl-trivial-open-browser))
+
+(define-public ecl-trivial-open-browser
+ (sbcl-package->ecl-package sbcl-trivial-open-browser))
+
(define-public sbcl-clinenoise
(let ((commit "46e21f99d06a55d93eaa382cf652d55d457032ef")
(revision "1"))