summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-12-10 06:10:52 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-12-11 10:46:16 +0100
commitd3b541469139040ddc3fb5bb37b1ac184572296d (patch)
treee46c866ac227a526c23b15ce7236eb3883c72b76 /gnu/packages/lisp-xyz.scm
parente9c6be11260b1487ee241855d8189e1441f6bf8d (diff)
downloadguix-patches-d3b541469139040ddc3fb5bb37b1ac184572296d.tar
guix-patches-d3b541469139040ddc3fb5bb37b1ac184572296d.tar.gz
gnu: Add cl-core-gp.
* gnu/packages/lisp-xyz.scm (cl-core-gp, ecl-core-gp, sbcl-core-gp): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0ac48db778..113f867ae5 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -19782,6 +19782,36 @@ score. When evaluated, the musical score is rendered to an image.")
(define-public ecl-cmn
(sbcl-package->ecl-package sbcl-cmn))
+(define-public sbcl-core-gp
+ (let ((commit "90ec1c4599a19c5a911be1f703f78d5108aee160")
+ (revision "1"))
+ (package
+ (name "sbcl-core-gp")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jorgetavares/core-gp")
+ (commit commit)))
+ (file-name (git-file-name "cl-core-gp" version))
+ (sha256
+ (base32 "0nzlb2gwqisa1amlpl4zc5xxph2g3qwhfyaxchci67d31rzws6l3"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/jorgetavares/core-gp")
+ (synopsis "Common Lisp library for genetic programming")
+ (description
+ "@code{core-gp} is a Common Lisp library for genetic programming (GP)
+algorithms. It allows standard GP, strongly-typed GP, grammatical evolution as
+well as standard genetic algorithms.")
+ (license license:expat))))
+
+(define-public cl-core-gp
+ (sbcl-package->cl-source-package sbcl-core-gp))
+
+(define-public ecl-core-gp
+ (sbcl-package->ecl-package sbcl-core-gp))
+
(define-public sbcl-data-sift
(let ((commit "fd617d8200cdcc1b87ecf45ab59bb38e8b16ef7e")
(revision "1"))