summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-17 05:41:07 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-19 10:48:41 +0100
commita35debac9747686722a2c4951b69c6f26e3b7b3c (patch)
tree29a920934658d9d6512a3758af9abef4efdf9704 /gnu/packages/lisp-xyz.scm
parentc7caeb33d63ce4a99beef478cfce20cc71e7cdda (diff)
downloadguix-patches-a35debac9747686722a2c4951b69c6f26e3b7b3c.tar
guix-patches-a35debac9747686722a2c4951b69c6f26e3b7b3c.tar.gz
gnu: Add cl-genhash.
* gnu/packages/lisp-xyz.scm (cl-genhash, ecl-genhash, sbcl-genhash): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index da03624c4a..332749e156 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18103,6 +18103,34 @@ bound to whatever value was in the same place in the URL (as a string).")
(define-public cl-hunchenissr-routes
(sbcl-package->cl-source-package sbcl-hunchenissr-routes))
+(define-public sbcl-genhash
+ (let ((commit "220ae1af8361dbd2005177f2ee11072b6a33934f")
+ (revision "1"))
+ (package
+ (name "sbcl-genhash")
+ (version (git-version "1.7" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pnathan/genhash")
+ (commit commit)))
+ (file-name (git-file-name "cl-genhash" version))
+ (sha256
+ (base32 "1jnk1fix1zydhy0kn3cvlp6dy0241x7v8ahq001nlr6v152z1cwk"))))
+ (build-system asdf-build-system/sbcl)
+ (home-page "https://github.com/pnathan/genhash")
+ (synopsis "Generic hash tables for Common Lisp")
+ (description
+ "This an implementation of CDR 2: generic hash tables for Common Lisp")
+ (license license:public-domain))))
+
+(define-public cl-genhash
+ (sbcl-package->cl-source-package sbcl-genhash))
+
+(define-public ecl-genhash
+ (sbcl-package->ecl-package sbcl-genhash))
+
(define-public sbcl-spinneret
;; No release since 2019, no tags.
(let ((commit "02451b32648eda4e6e4022bbb7f91d9ea71bebbc"))