summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-11-17 05:41:32 +0000
committerGuillaume Le Vaillant <glv@posteo.net>2021-11-19 10:48:41 +0100
commit641e3d1288a22cd1e81e153c7fb1877a70e52b22 (patch)
treeeb916e4b9f6947f68e0f6d88b1d795a7e8229c5c /gnu/packages/lisp-xyz.scm
parenta35debac9747686722a2c4951b69c6f26e3b7b3c (diff)
downloadguix-patches-641e3d1288a22cd1e81e153c7fb1877a70e52b22.tar
guix-patches-641e3d1288a22cd1e81e153c7fb1877a70e52b22.tar.gz
gnu: Add cl-path-parse.
* gnu/packages/lisp-xyz.scm (cl-path-parse, ecl-path-parse, sbcl-path-parse): New variables. Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 332749e156..69b04c8b67 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -18192,6 +18192,39 @@ semantics in Lisp and Parenscript.
(define-public cl-spinneret
(sbcl-package->cl-source-package sbcl-spinneret))
+(define-public sbcl-path-parse
+ (let ((commit "86183f3752374435f8933394b4c5d8e75a37a113")
+ (revision "1"))
+ (package
+ (name "sbcl-path-parse")
+ (version (git-version "0.1" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eudoxia0/path-parse")
+ (commit commit)))
+ (file-name (git-file-name "cl-path-parse" version))
+ (sha256
+ (base32 "10mxm6q62cfpv3hw2w8k968ba8a1xglqdkwlkqs4l4nby3b11aaq"))))
+ (build-system asdf-build-system/sbcl)
+ (inputs
+ `(("split-sequence" ,sbcl-split-sequence)))
+ (native-inputs
+ `(("fiveam" ,sbcl-fiveam)))
+ (home-page "https://github.com/eudoxia0/path-parse")
+ (synopsis "Parse the PATH environment variable in Common Lisp")
+ (description
+ "This package provides a function to parse the @code{PATH} environment
+variable portably in Common Lisp.")
+ (license license:expat))))
+
+(define-public cl-path-parse
+ (sbcl-package->cl-source-package sbcl-path-parse))
+
+(define-public ecl-path-parse
+ (sbcl-package->ecl-package sbcl-path-parse))
+
(define-public sbcl-cl-libxml2
(let ((commit "8d03110c532c1a3fe15503fdfefe82f60669e4bd"))
(package