summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp-xyz.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 16:48:37 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-06-18 17:14:08 +0200
commit797f43af75d61dcc91112f704c5c99c67f8b1fe7 (patch)
tree66bcda758a670f8693f2144f908b6eb994b7dfcd /gnu/packages/lisp-xyz.scm
parent6f517910226f65bf17e22d7baca9347d475f7a9e (diff)
downloadguix-patches-797f43af75d61dcc91112f704c5c99c67f8b1fe7.tar
guix-patches-797f43af75d61dcc91112f704c5c99c67f8b1fe7.tar.gz
gnu: sbcl-triva: Remove ASD component fix.
* gnu/packages/lisp-xyz.scm (sbcl-triva)[arguments]: Remove 'remove-component phase now that our build system supports component-less .asd files.
Diffstat (limited to 'gnu/packages/lisp-xyz.scm')
-rw-r--r--gnu/packages/lisp-xyz.scm19
1 files changed, 1 insertions, 18 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 0fcc5c005a..7b086000b4 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -6293,24 +6293,7 @@ This system contains the CFFI foreign slot access extension.")))
("trivia.cffi" ,sbcl-trivia.cffi)
("optima" ,sbcl-optima)))
(arguments
- `(#:test-asd-file "trivia.test.asd"
- #:phases
- (modify-phases %standard-phases
- (add-after 'create-asd 'remove-component
- ;; XXX: The original .asd has no components, but our build system
- ;; creates an entry nonetheless. We need to remove it for the
- ;; generated .asd to load properly. See trivia.trivial for a
- ;; similar problem.
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (asd (string-append out "/lib/" (%lisp-type) "/trivia.asd")))
- (substitute* asd
- ((" :components
-")
- ""))
- (substitute* asd
- ((" *\\(\\(:compiled-file \"trivia--system\"\\)\\)")
- ""))))))))
+ `(#:test-asd-file "trivia.test.asd"))
(description "Trivia is a pattern matching compiler that is compatible
with Optima, another pattern matching library for Common Lisp. It is meant to
be faster and more extensible than Optima.")))