summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-05-12 13:18:24 +0300
committerEfraim Flashner <efraim@flashner.co.il>2024-05-27 10:26:20 +0300
commitdd8364cfae6f666187eda62684cdbcd704fd9081 (patch)
tree83d90c371db94abf8727adb10c11c4e21cd948ee /gnu/packages/linux.scm
parenta3e5caa222d86c15f00b639c376bb5a866e269e8 (diff)
downloadguix-patches-dd8364cfae6f666187eda62684cdbcd704fd9081.tar
guix-patches-dd8364cfae6f666187eda62684cdbcd704fd9081.tar.gz
gnu: e2fsprogs: Downgrade to 1.46.6.
1.47.0 would, by default, create an ext4 filesystem which was not readable by our current version of grub. This should also address a number of the system test failures. * gnu/packages/linux.scm (e2fsprogs): Downgrade to 1.46.6. Change-Id: Ifa6841185ab85d24479f981afc1b42a349716d80
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ac5bef8920..c555ebdb47 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -2585,10 +2585,12 @@ Linux kernel module and the server needs the @file{usbip_host} Linux kernel
module.")
(license license:gpl2)))
+;; XXX: Before updating to 1.47+ check if grub supports the ext4 flag
+;; metadata_csum_seed, otherwise grub will complain about an unknown filesystem.
(define-public e2fsprogs
(package
(name "e2fsprogs")
- (version "1.47.0")
+ (version "1.46.6")
(source (origin
(method url-fetch)
(uri (string-append
@@ -2597,7 +2599,7 @@ module.")
"e2fsprogs-" version ".tar.xz"))
(sha256
(base32
- "1nymjw801lmlr5y6bg1zv9jsip5dkyxqislbdzpir4mx5czzajhl"))))
+ "1z7lqkvrw97jym2w2gz1aj3d9maxhrk6alv3vrzfkr7mkzqifxd7"))))
(build-system gnu-build-system)
(inputs (list `(,util-linux "lib")))
(native-inputs (list pkg-config