summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorWilko Meyer <w@wmeyer.eu>2024-05-13 11:30:52 +0200
committerLeo Famulari <leo@famulari.name>2024-05-26 14:51:32 -0400
commitcc728a393e4521beccd042614613616b3849bd3e (patch)
tree4cbf7a83fbd26f73ad31b0294615e09dd9f1f6eb /gnu/packages/linux.scm
parentdc8fb5672464b6386f6b4b94723f9b36edc4e625 (diff)
downloadguix-patches-cc728a393e4521beccd042614613616b3849bd3e.tar
guix-patches-cc728a393e4521beccd042614613616b3849bd3e.tar.gz
gnu: Add linux-libre 6.9.
Big thanks to Dariqq <dariqq@posteo.net> for debugging and communicating upstream about a problem with the deblobbing scripts in this kernel series! * gnu/packages/linux.scm (linux-libre-6.9-version, linux-libre-6.9-gnu-revision, deblob-scripts-6.9, linux-libre-6.9-pristine-source, linux-libre-6.9-source, linux-libre-headers-6.9, linux-libre-6.9): New variables. * gnu/packages/aux-files/linux-libre/6.9-arm.conf, gnu/packages/aux-files/linux-libre/6.9-arm64.conf, gnu/packages/aux-files/linux-libre/6.9-i686.conf, gnu/packages/aux-files/linux-libre/6.9-x86.conf: New files. * Makefile.am (AUX_FILES): Add them. Signed-off-by: Leo Famulari <leo@famulari.name> Change-Id: I8dc011a603684f0be88766b7881aa6c560b94443
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 67e924642e..e577c3790f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -501,6 +501,23 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(sha256 hash)))
+;; The current "mainline" kernel.
+
+(define-public linux-libre-6.9-version "6.9.2")
+(define-public linux-libre-6.9-gnu-revision "gnu")
+(define deblob-scripts-6.9
+ (linux-libre-deblob-scripts
+ linux-libre-6.9-version
+ linux-libre-6.9-gnu-revision
+ (base32 "1izfwmk0mxikx3bblcwiyrxdd4bg9v0jsph3i8gvrpjb7kw0lhna")
+ (base32 "0b8hsr0s4f3hps27bmd5qj1yknhd73q4zplr4v3lmq7sr57mgly6")))
+(define-public linux-libre-6.9-pristine-source
+ (let ((version linux-libre-6.9-version)
+ (hash (base32 "1yg5j284y1gz7zwxjz2abvlnas259m1y1vzd9lmcqqar5kgmnv6l")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-6.9)))
+
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
@@ -641,6 +658,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-6.9-source
+ (source-with-patches linux-libre-6.9-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-6.8-source
(source-with-patches linux-libre-6.8-pristine-source
(list %boot-logo-patch
@@ -761,6 +783,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-6.9
+ (make-linux-libre-headers* linux-libre-6.9-version
+ linux-libre-6.9-gnu-revision
+ linux-libre-6.9-source))
+
(define-public linux-libre-headers-6.8
(make-linux-libre-headers* linux-libre-6.8-version
linux-libre-6.8-gnu-revision
@@ -1105,6 +1132,14 @@ Linux kernel. It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-6.9
+ (make-linux-libre* linux-libre-6.9-version
+ linux-libre-6.9-gnu-revision
+ linux-libre-6.9-source
+ '("x86_64-linux" "i686-linux" "armhf-linux"
+ "aarch64-linux" "powerpc64le-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-6.8
(make-linux-libre* linux-libre-6.8-version
linux-libre-6.8-gnu-revision