summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-05 16:21:45 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-05 17:01:53 +0100
commit9a3d176ee1b49d4b6d8a7cf0a80512cfa61c0e61 (patch)
tree72c7427f4da226fbf48ef14a0149a84029475231 /gnu/packages/linux.scm
parent9eb7cde0e88698d8a630ebae60dd923780e0c566 (diff)
downloadguix-patches-9a3d176ee1b49d4b6d8a7cf0a80512cfa61c0e61.tar
guix-patches-9a3d176ee1b49d4b6d8a7cf0a80512cfa61c0e61.tar.gz
gnu: thinkfan: Update to 1.0.2.
* gnu/packages/linux.scm (thinkfan): Update to 1.0.2. [arguments]: Adjust source directory.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm39
1 files changed, 19 insertions, 20 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5cced33477..9f83f97cef 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -98,6 +98,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages rrdtool)
#:use-module (gnu packages samba)
+ #:use-module (gnu packages serialization)
#:use-module (gnu packages slang)
#:use-module (gnu packages storage)
#:use-module (gnu packages texinfo)
@@ -3483,29 +3484,26 @@ feature, and a laptop with an accelerometer. It has no effect on SSDs.")
(define-public thinkfan
(package
(name "thinkfan")
- (version "0.9.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/thinkfan/"
- "/thinkfan-" version ".tar.gz"))
- (sha256
- (base32
- "0nz4c48f0i0dljpk5y33c188dnnwg8gz82s4grfl8l64jr4n675n"))
- (modules '((guix build utils)))
- ;; Fix erroneous man page location in Makefile leading to
- ;; a compilation failure.
- (snippet '(begin
- (substitute* "CMakeLists.txt"
- (("thinkfan\\.1") "src/thinkfan.1"))
- #t))))
+ (version "1.0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vmatare/thinkfan.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "107vw0962hrwva3wra9n3hxlbfzg82ldc10qssv3dspja88g8psr"))))
(build-system cmake-build-system)
(arguments
`(#:modules ((guix build cmake-build-system)
(guix build utils)
(srfi srfi-26))
- #:tests? #f ;no test target
+ #:tests? #f ; no test target
#:configure-flags
;; Enable reading temperatures from hard disks via S.M.A.R.T.
+ ;; Upstream ‘defaults to OFF because libatasmart seems to be horribly
+ ;; inefficient’.
`("-DUSE_ATASMART:BOOL=ON")
#:phases
(modify-phases %standard-phases
@@ -3514,9 +3512,7 @@ feature, and a laptop with an accelerometer. It has no effect on SSDs.")
(add-after 'install 'install-rc-scripts
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
- (files (find-files
- (string-append "../thinkfan-" ,version "/rcscripts")
- ".*")))
+ (files (find-files "../source/rcscripts" ".*")))
(substitute* files
(("/usr/sbin/(\\$NAME|thinkfan)" _ name)
(string-append out "/sbin/" name)))
@@ -3524,8 +3520,11 @@ feature, and a laptop with an accelerometer. It has no effect on SSDs.")
(string-append out "/share/thinkfan"))
files))
#t)))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
- `(("libatasmart" ,libatasmart)))
+ `(("libatasmart" ,libatasmart)
+ ("yaml-cpp" ,yaml-cpp)))
(home-page "http://thinkfan.sourceforge.net/")
(synopsis "Simple fan control program")
(description