summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-22 15:43:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-22 15:58:32 +0100
commit6f78fe353e5cb5109eb1eed8727870a9e5efdb59 (patch)
treee8f64afd75228833e35e5a257f3368a0b8643d6b /gnu/packages/linux.scm
parent6aa8f213c42d30e16da0564b5a9afde22de03d60 (diff)
downloadguix-patches-6f78fe353e5cb5109eb1eed8727870a9e5efdb59.tar
guix-patches-6f78fe353e5cb5109eb1eed8727870a9e5efdb59.tar.gz
gnu: acpi-call-linux-module: Remove reference to bash.
* gnu/packages/linux.scm (acpi-call-linux-module)[arguments]: Add a ‘patch-shebangs-harder’ phase.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 159fa2a206..f19f8e2051 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1059,6 +1059,14 @@ It has been modified to remove all non-free binary blobs.")
`(#:tests? #f ; no tests
#:phases
(modify-phases %standard-phases
+ (add-before 'install 'patch-shebangs-harder
+ ;; The (only) shebangs in examples/ don't justify a reference.
+ ;; However, do substitute a more portable one than the original.
+ (lambda _
+ (substitute* (find-files "examples" ".")
+ (("^(#! *)/[^ ]*/" _ shebang)
+ (string-append shebang "/usr/bin/env ")))
+ #t))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))