summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-15 02:00:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-15 02:00:06 +0200
commit014f97544dbe4f08405320d129a1a5d9c1f775f0 (patch)
treef22c5381a3db10d3026ace7c2e13c26d526594d2 /gnu/packages/linux.scm
parentfac0e3cb80dabf05cb5941804fc4d5913de644f3 (diff)
downloadguix-patches-014f97544dbe4f08405320d129a1a5d9c1f775f0.tar
guix-patches-014f97544dbe4f08405320d129a1a5d9c1f775f0.tar.gz
gnu: btrfs-progs: Fix cross-compilation.
* gnu/packages/linux.scm (btrfs-progs)[arguments]: Add "--disable-python" support to #:configure-flags. [inputs]: Move eudev here… [native-inputs]: …from here. Reported by Pavel Shlyak <p.shlyak@pantherx.org>.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8c29776b64..7b564e7ef1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -5549,7 +5549,11 @@ and copy/paste text in the console and in xterm.")
(outputs '("out"
"static")) ; static versions of the binaries in "out"
(arguments
- '(#:phases (modify-phases %standard-phases
+ '(#:configure-flags
+ ;; The ‘Python support’ was never actually installed by previous
+ ;; versions of this package, but did prevent cross-compilation.
+ (list "--disable-python")
+ #:phases (modify-phases %standard-phases
(add-after 'unpack 'patch-makefile
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "Makefile"
@@ -5576,6 +5580,7 @@ and copy/paste text in the console and in xterm.")
#:test-target "test"
#:parallel-tests? #f)) ; tests fail when run in parallel
(inputs `(("e2fsprogs" ,e2fsprogs) ; for btrfs-convert
+ ("eudev" ,eudev)
("lzo" ,lzo)
("util-linux:lib" ,util-linux "lib") ;for libblkid and libuuid
("util-linux:static" ,util-linux "static") ;ditto
@@ -5594,7 +5599,6 @@ and copy/paste text in the console and in xterm.")
("acl" ,acl)
("which" ,which)
("dmsetup" ,lvm2)
- ("udevadm" ,eudev)
;; The tests need 'grep' with perl regexp support.
("grep" ,grep)))
(home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")