summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-23 22:50:07 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-23 22:50:07 +0100
commit3cb61ca85a634db2dcc2badaf3492440bf621d92 (patch)
tree72561a5f7056aa29cec7d50fb8b960b32b44a585 /gnu/packages/linux.scm
parenta60370727a77d1658307698276239c153d8279e8 (diff)
parentf92854fea150f0d47c4984f87bf21bd5f8051820 (diff)
downloadguix-patches-3cb61ca85a634db2dcc2badaf3492440bf621d92.tar
guix-patches-3cb61ca85a634db2dcc2badaf3492440bf621d92.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index da7dd1f550..2140d5c6a5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2018, 2019 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -4277,7 +4277,7 @@ Light is the successor of lightscript.")
(define-public tlp
(package
(name "tlp")
- (version "1.1")
+ (version "1.2.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -4287,7 +4287,7 @@ Light is the successor of lightscript.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "068hzmh90x600saynbl7iwg1pm0ywldn4jazyxx5y1fixs8s1qbn"))))
+ "0rcp9i0fisdm4h6799ffr696l1vl661fnwb2dij268nlwwmkr90g"))))
(inputs `(("bash" ,bash)
("dbus" ,dbus)
("ethtool" ,ethtool)
@@ -4317,7 +4317,8 @@ Light is the successor of lightscript.")
(setenv "TLP_NO_PMUTILS" "1")
(setenv "TLP_SBIN" (string-append out "/bin"))
(setenv "TLP_BIN" (string-append out "/bin"))
- (setenv "TLP_TLIB" (string-append out "/share/tlp-pm"))
+ (setenv "TLP_TLIB" (string-append out "/share/tlp"))
+ (setenv "TLP_FLIB" (string-append out "/share/tlp/func.d"))
(setenv "TLP_ULIB" (string-append out "/lib/udev"))
(setenv "TLP_CONF" "/etc/tlp")
(setenv "TLP_SHCPL"
@@ -4371,7 +4372,6 @@ Light is the successor of lightscript.")
a default configuration already optimized for battery life. Nevertheless,
TLP is customizable to fulfil system requirements. TLP settings are applied
every time the power supply source is changed.")
-
;; 'COPYING' is a custom version that says that one file is GPLv3+ and the
;; rest is GPLv2+.
(license (list license:gpl2+ license:gpl3+))))