summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-06-03 23:32:15 -0400
committerMark H Weaver <mhw@netris.org>2018-06-05 17:21:03 -0400
commitdb89d31876d2f02da1e550813b3e34d9cd605633 (patch)
tree31880323fc1e57642a4d6b2d2234830a21459736 /gnu/packages/linux.scm
parent704051b2583842da05b9a77fdea98e7380ca611e (diff)
downloadguix-patches-db89d31876d2f02da1e550813b3e34d9cd605633.tar
guix-patches-db89d31876d2f02da1e550813b3e34d9cd605633.tar.gz
gnu: linux-libre: Update to 4.17.
* gnu/packages/linux.scm (%linux-libre-version): Update to 4.17. (%linux-libre-hash): Update hash. * gnu/packages/aux-files/linux-libre/4.16-arm.conf, gnu/packages/aux-files/linux-libre/4.16-arm64.conf, gnu/packages/aux-files/linux-libre/4.16-i686.conf, gnu/packages/aux-files/linux-libre/4.16-x86_64.conf: Delete files. * gnu/packages/aux-files/linux-libre/4.17-arm.conf, gnu/packages/aux-files/linux-libre/4.17-arm64.conf, gnu/packages/aux-files/linux-libre/4.17-i686.conf, gnu/packages/aux-files/linux-libre/4.17-x86_64.conf: New files. * Makefile.am (AUX_FILES): Adjust accordingly.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index a641f8fbe5..3049a4d523 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -395,8 +395,8 @@ It has been modified to remove all non-free binary blobs.")
;; supports qemu "virt" machine and possibly a large number of ARM boards.
;; See : https://wiki.debian.org/DebianKernel/ARMMP.
-(define %linux-libre-version "4.16.13")
-(define %linux-libre-hash "1frpqxv5ykf87hrmh62b8nxxcpv64a5w7lxw51z4vs82799inmng")
+(define %linux-libre-version "4.17")
+(define %linux-libre-hash "0abbqrq96kn97jr02mf4ahqg7hl9vhq95c1l2z0s7jqrmhv1n8pb")
(define-public linux-libre
(make-linux-libre %linux-libre-version