summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-05-31 04:17:22 -0400
committerMark H Weaver <mhw@netris.org>2018-05-31 04:17:22 -0400
commit966e9575a3a110d14f37acb43b5f605737a7a4a3 (patch)
treedcb93cd519a0762ba55c24c941fb534c412c8150 /gnu/packages/linux.scm
parent55b68174aa44e38eb396e83994edcfcfcdf3b234 (diff)
downloadguix-patches-966e9575a3a110d14f37acb43b5f605737a7a4a3.tar
guix-patches-966e9575a3a110d14f37acb43b5f605737a7a4a3.tar.gz
gnu: linux-libre@4.14: Update to 4.14.47.
* gnu/packages/linux.scm (%linux-libre-4.14-version): Update to 4.14.47. (%linux-libre-4.14-hash): Update hash. (linux-libre-arm-generic-4.14, linux-libre-arm-omap2plus-4.14) (linux-libre-4.14): Remove patch.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm31
1 files changed, 2 insertions, 29 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b218ccbceb..da994d8ac9 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -404,22 +404,13 @@ It has been modified to remove all non-free binary blobs.")
%linux-compatible-systems
#:configuration-file kernel-config))
-(define %linux-libre-4.14-version "4.14.46")
-(define %linux-libre-4.14-hash "17imkhqk3m3djdj0m5h4lqs9cfdh9zq1cz83q8ldyald56rbn622")
+(define %linux-libre-4.14-version "4.14.47")
+(define %linux-libre-4.14-hash "1hm1vk6cdrwr971g5rcbq425fadn49580xa27zp1h6jz40n119wd")
(define-public linux-libre-4.14
(make-linux-libre %linux-libre-4.14-version
%linux-libre-4.14-hash
'("x86_64-linux" "i686-linux" "armhf-linux")
- #:patches
- (list %boot-logo-patch
- (origin
- ;; The sole fix in the 4.14.47 release.
- (method url-fetch)
- (uri "https://git.kernel.org/pub/scm/linux/kernel/\
-git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
- (sha256
- (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:configuration-file kernel-config))
(define-public linux-libre-4.9
@@ -452,15 +443,6 @@ git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "multi_v7_defconfig"
- #:patches
- (list %boot-logo-patch
- (origin
- ;; The sole fix in the 4.14.47 release.
- (method url-fetch)
- (uri "https://git.kernel.org/pub/scm/linux/kernel/\
-git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
- (sha256
- (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-generic"))
(define-public linux-libre-arm-omap2plus
@@ -475,15 +457,6 @@ git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
%linux-libre-4.14-hash
'("armhf-linux")
#:defconfig "omap2plus_defconfig"
- #:patches
- (list %boot-logo-patch
- (origin
- ;; The sole fix in the 4.14.47 release.
- (method url-fetch)
- (uri "https://git.kernel.org/pub/scm/linux/kernel/\
-git/stable/linux-stable.git/patch/?id=3e496be2038a100fc53627238fe120dc4c948719")
- (sha256
- (base32 "1hk1qd6v97zf8an3zww60zhsah1wwax22b3bpdzmfjhhbndyram9"))))
#:extra-version "arm-omap2plus"))