summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-02-11 04:05:07 -0500
committerMark H Weaver <mhw@netris.org>2018-02-11 04:05:07 -0500
commita7fb29866520d5661e0ac8e47957c91a2a43e11e (patch)
tree50a169b022edbb31db49f09809d30dfe8597b862 /gnu/packages/linux.scm
parent6730d895d3992f37f35f5351332f51a4be2fda50 (diff)
parent31c7002b466c6d09400a95bc15774f232b51ce0b (diff)
downloadguix-patches-a7fb29866520d5661e0ac8e47957c91a2a43e11e.tar
guix-patches-a7fb29866520d5661e0ac8e47957c91a2a43e11e.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b0cefeab75..a3a4737d59 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2016, 2017 Alex Kost <alezost@gmail.com>
;;; Copyright © 2016 Raymond Nicholson <rain1@openmailbox.org>
;;; Copyright © 2016 Mathieu Lirzin <mthl@gnu.org>
-;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2016, 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -3944,7 +3944,7 @@ Light is the successor of lightscript.")
(define-public tlp
(package
(name "tlp")
- (version "1.0")
+ (version "1.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -3954,7 +3954,7 @@ Light is the successor of lightscript.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1v3qpj9kp4rxwqapayd0i9419wwv4bikyrzjvqn0r9xkgnr1f9v4"))))
+ "068hzmh90x600saynbl7iwg1pm0ywldn4jazyxx5y1fixs8s1qbn"))))
(inputs `(("bash" ,bash)
("dbus" ,dbus)
("ethtool" ,ethtool)
@@ -3989,7 +3989,8 @@ Light is the successor of lightscript.")
(setenv "TLP_CONF" "/etc/tlp")
(setenv "TLP_SHCPL"
(string-append out "/share/bash-completion/completions"))
- (setenv "TLP_MAN" (string-append out "/share/man")))))
+ (setenv "TLP_MAN" (string-append out "/share/man"))
+ (setenv "TLP_META" (string-append out "/share/metainfo")))))
(delete 'check) ; no tests
(add-before 'install 'fix-installation
(lambda _
@@ -3997,7 +3998,8 @@ Light is the successor of lightscript.")
(substitute* "Makefile" (("\\[ -f \\$\\(_CONF\\) \\]") "#"))))
(replace 'install
(lambda _
- (zero? (system* "make" "install-tlp" "install-man"))))
+ (invoke "make" "install-tlp" "install-man")
+ #t))
(add-after 'install 'wrap
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((bin (string-append (assoc-ref outputs "out") "/bin"))