summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorfesoj000 <fesoj000@gmail.com>2022-03-27 00:34:23 +0100
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:49:46 +0200
commitfdfd6ac8ae19ddd054bd7a0934f4403fa573306e (patch)
treeaff148bf43acf700ffff5f035f3128cc011e2588 /gnu/packages/linux.scm
parent6d9cfb91aaeb8a2f3bb4db223c440a6cc396ea32 (diff)
downloadguix-patches-fdfd6ac8ae19ddd054bd7a0934f4403fa573306e.tar
guix-patches-fdfd6ac8ae19ddd054bd7a0934f4403fa573306e.tar.gz
gnu: Add libnetfilter-queue
* gnu/packages/linux.scm (libnetfilter-queue): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 90940912a8..a197954ff3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7379,6 +7379,30 @@ list existing registered user-space connection tracking helpers
(supported-systems (filter target-linux? %supported-systems))
(license license:gpl2+)))
+(define-public libnetfilter-queue
+ (package
+ (name "libnetfilter-queue")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://netfilter.org/projects/"
+ "libnetfilter_queue/files/"
+ "libnetfilter_queue-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1xdra6i4p8jkv943ygjw646qx8df27f7p5852kc06vjx608krzzr"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libmnl libnfnetlink))
+ (synopsis "Library for kernel netfilter infrastructure and state")
+ (description "libnetfilter_queue is a userspace library providing an API
+to packets that have been queued by the kernel packet filter. It is is part
+of a system that deprecates the old ip_queue/libipq mechanism.")
+ (home-page "https://netfilter.org/projects/libnetfilter_queue/index.html")
+ (supported-systems (filter target-linux? %supported-systems))
+ (license license:gpl2+)))
+
(define-public proot
(package
(name "proot")