summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorfesoj000 <fesoj000@gmail.com>2022-03-27 00:34:27 +0100
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:51:07 +0200
commiteb1d2ae7e028910a5fcf936d909c9c2dad01fe1a (patch)
treef0132eda8bacf7941ef3e26b360c0fb29d7cfb42 /gnu/packages/linux.scm
parent2d3c33b8ba1d4d418737459ec56eea908ecc1760 (diff)
downloadguix-patches-eb1d2ae7e028910a5fcf936d909c9c2dad01fe1a.tar
guix-patches-eb1d2ae7e028910a5fcf936d909c9c2dad01fe1a.tar.gz
gnu: Add nfacct
* gnu/packages/linux.scm (nfacct): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3bc13d9867..d9e04f22d3 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7475,6 +7475,38 @@ For the nfnetlink_acct subsystem.")
(supported-systems (filter target-linux? %supported-systems))
(license license:lgpl2.1+)))
+(define-public nfacct
+ (package
+ (name "nfacct")
+ (version "1.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://netfilter.org/projects/" name
+ "/files/nfacct-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0sdxbxjyapbqcp2ami5jd10vz4xbbdvx39f3wfy1iqsbflc25zzc"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libmnl libnetfilter-acct))
+ (synopsis "Command line tool to create/retrieve/delete accounting objects")
+ (description "nfacct is the command line tool to create/retrieve/delete
+accounting objects
+@enumerate
+@item
+listing the objects of the nfacct table in plain text/XML
+@item
+atomically get and reset objects of the nfacct table
+@item
+adding new objects to the nfacct table
+@item
+deleting objects from the nfacct table
+@end enumerate")
+ (home-page "https://netfilter.org/projects/nfacct/index.html")
+ (supported-systems (filter target-linux? %supported-systems))
+ (license license:gpl2+)))
+
(define-public proot
(package
(name "proot")