summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-03-10 13:15:24 -0500
committerLeo Famulari <leo@famulari.name>2022-03-26 17:59:57 -0400
commit943d4b775b9b1cc645e86206b0cf07da8d0030b3 (patch)
tree959f53944ab084c7dc071f6db589db0ecae78cc3 /gnu/packages/linux.scm
parent50ccffb89e3dbb71a415b9c84b955006fe44fe02 (diff)
downloadguix-patches-943d4b775b9b1cc645e86206b0cf07da8d0030b3.tar
guix-patches-943d4b775b9b1cc645e86206b0cf07da8d0030b3.tar.gz
gnu: linux-libre: Add linux-libre 5.17.
* gnu/packages/linux.scm (linux-libre-5.17-version, linux-libre-5.17-gnu-revision, deblob-scripts-5.17, linux-libre-5.17-pristine-source, linux-libre-5.17-source, linux-libre-headers-5.17, linux-libre-5.17): New variables. * gnu/packages/aux-files/linux-libre/5.17-arm.conf, gnu/packages/aux-files/linux-libre/5.17-arm64.conf, gnu/packages/aux-files/linux-libre/5.17-i686.conf, gnu/packages/aux-files/linux-libre/5.17-x86_64.conf: New files. * Makefile.am (AUX_FILES): Add them.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index aaa3ff4808..72eb106ec2 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -359,6 +359,21 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The current "stable" kernels. That is, the most recently released major
;; versions that are still supported upstream.
+(define-public linux-libre-5.17-version "5.17")
+(define-public linux-libre-5.17-gnu-revision "gnu")
+(define deblob-scripts-5.17
+ (linux-libre-deblob-scripts
+ linux-libre-5.17-version
+ linux-libre-5.17-gnu-revision
+ (base32 "08ip5g827f30qzb3j2l19zkbdqv00sij46nbrjg75h5kkasdbfgr")
+ (base32 "0d4wmgirn2b7bv99f8ckfpcagwd2pylzn1sd6jz6d2apdfdspi0g")))
+(define-public linux-libre-5.17-pristine-source
+ (let ((version linux-libre-5.17-version)
+ (hash (base32 "1cdi43x4c3l4chznh57gm55szycj4wjlxl1dss1ilnfvvmhyypsm")))
+ (make-linux-libre-source version
+ (%upstream-linux-source version hash)
+ deblob-scripts-5.17)))
+
(define-public linux-libre-5.16-version "5.16.17")
(define-public linux-libre-5.16-gnu-revision "gnu")
(define deblob-scripts-5.16
@@ -495,6 +510,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(patches (append (origin-patches source)
patches))))
+(define-public linux-libre-5.17-source
+ (source-with-patches linux-libre-5.17-pristine-source
+ (list %boot-logo-patch
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
+
(define-public linux-libre-5.16-source
(source-with-patches linux-libre-5.16-pristine-source
(list %boot-logo-patch
@@ -608,6 +628,11 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(description "Headers of the Linux-Libre kernel.")
(license license:gpl2)))
+(define-public linux-libre-headers-5.17
+ (make-linux-libre-headers* linux-libre-5.17-version
+ linux-libre-5.17-gnu-revision
+ linux-libre-5.17-source))
+
(define-public linux-libre-headers-5.16
(make-linux-libre-headers* linux-libre-5.16-version
linux-libre-5.16-gnu-revision
@@ -923,6 +948,13 @@ It has been modified to remove all non-free binary blobs.")
;;; Generic kernel packages.
;;;
+(define-public linux-libre-5.17
+ (make-linux-libre* linux-libre-5.17-version
+ linux-libre-5.17-gnu-revision
+ linux-libre-5.17-source
+ '("x86_64-linux" "i686-linux" "armhf-linux" "aarch64-linux" "riscv64-linux")
+ #:configuration-file kernel-config))
+
(define-public linux-libre-5.16
(make-linux-libre* linux-libre-5.16-version
linux-libre-5.16-gnu-revision