summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorfesoj000 <fesoj000@gmail.com>2022-03-27 00:34:26 +0100
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:51:06 +0200
commit2d3c33b8ba1d4d418737459ec56eea908ecc1760 (patch)
tree9f4c5d42a362a9812ad74a70e7ada37f5641079d /gnu/packages/linux.scm
parentf70c8a0276702510afb9fdfda46c61e3cbaf5f2b (diff)
downloadguix-patches-2d3c33b8ba1d4d418737459ec56eea908ecc1760.tar
guix-patches-2d3c33b8ba1d4d418737459ec56eea908ecc1760.tar.gz
gnu: Add libnetfilter-acct
* gnu/packages/linux.scm (libnetfilter-acct): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 7e3f348a9d..3bc13d9867 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7442,6 +7442,39 @@ similar to nftables.")
(supported-systems (filter target-linux? %supported-systems))
(license license:gpl2+)))
+(define-public libnetfilter-acct
+ (package
+ (name "libnetfilter-acct")
+ (version "1.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://netfilter.org/projects/"
+ "libnetfilter_acct/files/"
+ "libnetfilter_acct-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "06lsjndgfjsgfjr43px2n2wk3nr7whz6r405mks3887y7vpwwl22"))))
+ (build-system gnu-build-system)
+ (native-inputs (list pkg-config))
+ (inputs (list libmnl))
+ (synopsis "Library providing interface to extended accounting infrastructure")
+ (description "libnetfilter_acct is the userspace library providing interface
+to extended accounting infrastructure.
+
+@enumerate
+@item
+creating accounting objects
+@item
+retrieving accounting objects (and atomically set to zero)
+@item
+deleting accounting objects
+@end enumerate
+For the nfnetlink_acct subsystem.")
+ (home-page "https://netfilter.org/projects/libnetfilter_acct/index.html")
+ (supported-systems (filter target-linux? %supported-systems))
+ (license license:lgpl2.1+)))
+
(define-public proot
(package
(name "proot")