summaryrefslogtreecommitdiff
path: root/gnu/packages/linux.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-04-11 13:57:15 +0200
committerLudovic Courtès <ludo@gnu.org>2022-04-11 13:58:46 +0200
commit087abdb9a2cd2634a2bec3e5a2ecfe94d8f39417 (patch)
tree0002636b4d281a41595eefbf231a465cf388e048 /gnu/packages/linux.scm
parentb805ea194a61b249572aef05d06741c0bfb696eb (diff)
downloadguix-patches-087abdb9a2cd2634a2bec3e5a2ecfe94d8f39417.tar
guix-patches-087abdb9a2cd2634a2bec3e5a2ecfe94d8f39417.tar.gz
gnu: Add 'upstream-name' property to the netfilter libraries.
This allows the 'generic-html' updater to find updates. * gnu/packages/linux.scm (libnetfilter-conntrack)[properties]: New field. (libnetfilter-cttimeout)[properties]: New field. (libnetfilter-cthelper)[properties]: New field. (libnetfilter-queue)[properties]: New field. (libnetfilter-acct)[properties]: New field. (libnetfilter-log)[properties]: New field.
Diffstat (limited to 'gnu/packages/linux.scm')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e3b72326d1..c31113377c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7322,6 +7322,7 @@ libnfnetlink_conntrack and libctnetlink. This library is currently used by
conntrack-tools among many other applications.")
(home-page "https://netfilter.org/projects/libnetfilter_conntrack/index.html")
(supported-systems (filter target-linux? %supported-systems))
+ (properties '((upstream-name . "libnetfilter_conntrack")))
(license license:gpl2+)))
(define-public libnetfilter-cttimeout
@@ -7348,6 +7349,7 @@ timeout policies that can be attached to traffic flows. This library is used
by conntrack-tools.")
(home-page "https://netfilter.org/projects/libnetfilter_cttimeout/index.html")
(supported-systems (filter target-linux? %supported-systems))
+ (properties '((upstream-name . "libnetfilter_cttimeout")))
(license license:gpl2)))
(define-public libnetfilter-cthelper
@@ -7379,6 +7381,7 @@ list existing registered user-space connection tracking helpers
@end enumerate")
(home-page "https://netfilter.org/projects/libnetfilter_cthelper/index.html")
(supported-systems (filter target-linux? %supported-systems))
+ (properties '((upstream-name . "libnetfilter_cthelper")))
(license license:gpl2+)))
(define-public libnetfilter-queue
@@ -7403,6 +7406,7 @@ to packets that have been queued by the kernel packet filter. It is is part
of a system that deprecates the old ip_queue/libipq mechanism.")
(home-page "https://netfilter.org/projects/libnetfilter_queue/index.html")
(supported-systems (filter target-linux? %supported-systems))
+ (properties '((upstream-name . "libnetfilter_queue")))
(license license:gpl2+)))
(define-public conntrack-tools
@@ -7474,6 +7478,7 @@ deleting accounting objects
For the nfnetlink_acct subsystem.")
(home-page "https://netfilter.org/projects/libnetfilter_acct/index.html")
(supported-systems (filter target-linux? %supported-systems))
+ (properties '((upstream-name . "libnetfilter_acct")))
(license license:lgpl2.1+)))
(define-public nfacct
@@ -7536,6 +7541,7 @@ receiving to-be-logged packets from the kernel nfnetlink_log subsystem
@end enumerate")
(home-page "https://netfilter.org/projects/libnetfilter_log/index.html")
(supported-systems (filter target-linux? %supported-systems))
+ (properties '((upstream-name . "libnetfilter_log")))
(license license:gpl2+)))
(define-public ulogd